Algorithmique : deuxième partie

publicité
Algorithmique : deuxième partie
{
n
si n est pair
f
n=
ℕ
On souhaite construire la représentation de la fonction f définie sur
par
.
2
3 n1 si n est impair
On souhaite calculer f(n) et représenter les points de coordonnées  n ; f n pour 1≤n≤N .
Programme I : Calcul de f(n)
1° Calculer les images de 0, 1,2, 3, 50, 51 par la fonction f.
2° Le résultat dépend donc de la nature de l'antécédent n, il faut utiliser une condition SI-ALORS-SINON.
Principe de fonctionnement : SI « condition » ALORS «conséquence 1 » SINON « conséquence 2 »(1)
Compléter alors l'algorithme
ALGORITHME
Saisie
Saisir N
: Input"N=" , N
"N=" ↵
?N ↵
Traitement
:If fPart (N/2)=0
If Frac(N÷2)=0 ↵
: Then
Then ...........  Y ↵
SI…......................
TEXAS
CASIO
ALORS Y prend la valeur ..........
: ............  Y
…......... Y prend la valeur 3×N1
:ELSE
:3*N+1  Y
Else 3×N1  Y ↵
:End
I-End ↵
FIN SI
Sortie
"Y=" ↵
: Disp"Y=",Y
................................
Y
(1)Remarque : Cette fonction existe aussi sous la forme SI « condition » ALORS «conséquence 1 »
3° Vérifier alors à ma machine à calculer les résultats du 1°
Programme II : Calcul, pour plusieurs valeurs consécutives de n, de f(n)
On va demander d'entrer une valeur N (par exemple 10) pour afficher tous les résultats de f(i) pour i variant de
1 à 10. Cela nous permettra de mieux comprendre la construction de la représentation graphique de f.
Pour répéter plusieurs fois une opération avec un nombre connu de répétitions (la valeur N que l'on sasit) on
utilise une boucle FOR I=1 TO N -DO : Pour I de 1 jusqu'à N faire ....
ALGORITHME
TEXAS
CASIO
Saisie
Saisir N
Traitement
Pour I de 1 jusqu'à N
Si N est pair
ALORS Y prend la valeur...........
SINON .......................................
Fin Si
Afficher Y
Fin Pour
:................................
......................... ↵
:FOR(I,1,N)
: If .......................................
: Then
: ...............................
: Else
: ................................
: End
: Disp Y
:End
For 1  I To N ↵
If ......................... ↵
Then ......................↵
Else........................↵
IfEnd↵
Y
Sortie
Programme III : Représentation graphique de f
En s'inspirant du programme II, écrire l'algorithme puis le programme qui permet de représenter la fonction f,
pour 1≤n≤N .
Pour commander la construction du point de coordonnées (X;Y), on utilisera dans l'algorithme : "Marquer le
point de coordonnées (...;...)" .
On utilisera les commandes graphiques décrites dans le tableau pour traduire en langage machine.
Traduction de commandes d'algorithme en langage machine TEXAS et CASIO
Commandes
TEXAS
CASIO
Affichage d'un texte de saisie: X=
"X=" : 'affichage de =' 2nd TEST-1
"X=" : affichage de " SYBL
Saisie d'une valeur X
Input X :PRGM-E/S-1
Affichage et Saisie de X
Input "X=",X
"X=" ↵
? X
Affichage d'une valeur de sortie Y
Disp Y :PRGM-E/S-3
Y
SI (contrôle ou commande)
If : PRGM-CTL-1
If: 2nd-VARS-COM-If
Partie décimale : (math numérique)
fPart : MATH-NUM-4
Frac : OPTN-NUM-Frac
ALORS (contrôle-commande)
Then : PRGM-CTL-2
Then : 2nd-VARS-COM-Then
SINON (contrôle-commande)
Else : PRGM-CTL-3
Else : 2nd-VARS-COM-Else
Fin SI (contrôle-commande)
End: PRGM-CTL-7
I-End : 2nd-VARS-COM-IEnd
? X : 2nd-PRGM-?
Pour I de 1 à N (contrôle-commande) FOR(I,1,N): PRGM-CTL-4
For 1  I To N: 2nd-VARS-COM-For
Fin Pour (contrôle-commande)
End: PRGM-CTL-7
Next : 2nd-VARS-COM-Next
Construire Point (X;Y) (graphique)
Pt-On(X,Y): 2ndDRAW-POINTS-1 PlotOn X,Y : 2nd-Sketch-PLOT-PlOn
Fin Programme
: 2nd-PRGM
Traduction de commandes d'algorithme en langage machine TEXAS et CASIO
Commandes
TEXAS
CASIO
Affichage d'un texte de saisie: X=
"X=" : 'affichage de =' 2nd TEST-1
"X=" : affichage de " SYBL
Saisie d'une valeur X
Input X :PRGM-E/S-1
Affichage et Saisie de X
Input "X=",X
"X=" ↵
? X
Affichage d'une valeur de sortie Y
Disp Y :PRGM-E/S-3
Y
SI (contrôle ou commande)
If : PRGM-CTL-1
If: 2nd-VARS-COM-If
Partie décimale : (math numérique)
fPart : MATH-NUM-4
Frac : OPTN-NUM-Frac
ALORS (contrôle-commande)
Then : PRGM-CTL-2
Then : 2nd-VARS-COM-Then
SINON (contrôle-commande)
Else : PRGM-CTL-3
Else : 2nd-VARS-COM-Else
Fin SI (contrôle-commande)
End: PRGM-CTL-7
I-End : 2nd-VARS-COM-IEnd
? X : 2nd-PRGM-?
Pour I de 1 à N (contrôle-commande) FOR(I,1,N): PRGM-CTL-4
For 1  I To N: 2nd-VARS-COM-For
Fin Pour (contrôle-commande)
End: PRGM-CTL-7
Next : 2nd-VARS-COM-Next
Construire Point (X;Y) (graphique)
Pt-On(X,Y): 2ndDRAW-POINTS-1 PlotOn X,Y : 2nd-Sketch-PLOT-PlOn
Fin Programme
: 2nd-PRGM
Téléchargement
Random flashcards
Ce que beaucoup devaient savoir

0 Cartes Jule EDOH

Le lapin

5 Cartes Christine Tourangeau

découpe grammaticale

0 Cartes Beniani Ilyes

relation publique

2 Cartes djouad hanane

Algorithme

3 Cartes trockeur29

Créer des cartes mémoire