Fonctionnement du logiciel

advertisement
INTRODCTION
Dans ce cour nous avons présentons quelques Application concernant l’utilisation dulogiciel
OptGeo, dans un cadre des activités de simulation scientifique. Il s’agit d’un
logicield'apprentissage destiné à permettre aux élèves de créer des systèmes optique réfléchir
sur leurcomportement et éventuellement sur leurs limites de validité. optgeo est
unenvironnement ouvert permettant de travailler sur des entités (représentant des images des
objets) et surleurs propriétés (représentant des concepts) qui se lient par des relations d’ordre
qualitatif.
Fonctionnement du logiciel optgeo
OptGeo est un logiciel d’optique géométrique libre. Initialement développé en Delphi/Kylix,
il l’est maintenant sousLazarus. Il est très simple d’utilisation.01 Les exemples fournis sont
nombreux.
Après avoir choisi les dimensions de l’espace de travail, on dépose sur celui ci des miroirs
(plans, sphériques, paraboliques, hyperboliques, elliptiques), des lentilles (minces ou
épaisses), des volumes réfractants (sphères, prismes, lames, polyhèdres), des éléments divers
(écrans, diaphragmes, lames semi-réfléchissantes), ainsi que des sources (ponctuelles réelles,
ponctuelles virtuelles, ondes planes, rayons uniques). Optgéo trace les rayons lumineux., en
utilisant les lois de Descartes. On peut aussi, dans certains cas, tracer des surfaces d'onde.
Le répertoire "exemples" contient un certain nombre de simulations toutes faites.
la fenêtre principale de logiciel se divise principalement en 3 parties :
1ère partie
2ème partie
3ème partie
pour la premiere partie :constituer des différents onglets de travail deux vont être
particulièrement utilisés, il s’agit des onglets Fichier et option indiqués dans la figure si
dessous.
pour l’onglet Fichier Permet de choisir les attributs par défaut des éléments à la création
(couleur, épaisseur, police...).
L’onglet
Options
permet
de
choisir
les
informations sur la grille utilisé, les normales,
mesure des angles …
Grille
On peut utiliser une grille pour le repérage des
points et/ou leur saisie. Pour cela, passer par le
menu "Options".
Si "Attraction de la grille" est coché, lors de la
saisie d'un point, c'est le point le plus proche
appartenant à la grille qui est validé. Ceci est vrai
lors de l'ajout d'éléments et lors de leur
translation.
Dans certaines situations, l'attraction n'est pas appliquée; c'est le cas par exemple lors de la
saisie du foyer d'une lentille: les bords de la lentille étant déjà choisis, l'axe focal est imposé, et
le foyer ne peut pas être placé forcément sur un point de la grille.
L'affichage de la grille peut être activé directement par la case à cocher "Afficher la grille" dans
la barre d’outils.
Normales
On peut demander à ce que les normales aux dioptres et aux miroirs soient affichées. Pour
cela, passer par le menu "Options" puis "Afficher les normales", ou par la case à cocher
"Afficher les normales" dans la barre d'outil. Un paramétrage plus fin du tracé peut être
obtenu par le menu "Options", puis "Options des normales".
Les angles
On peut aussi demander à ce que les angles d'incidence et de réfraction soient affichés, soit
par le menu "Options" puis "Afficher les angles", soit par la case à cocher "Afficher les angles
d'incidence et de réfraction" dans la barre d'outil.
Remarque:
1)
l'option
affichage
des
angles
impose
l'option
affichage
des
normales
2) les valeurs des angles sont données en °; le nombre de décimales affichées peut être réglé
en passant par le menu "Options" puis "Options des normales".
3) pour les éléments optiques "idéalisés" (lentilles minces, miroirs sphériques paraxiaux), les
normales et angles ne sont pas tracés, puisque la représentation symbolique de ces éléments
en gomme la forme réelle.
Couleur de fond
Permet de changer la couleur de fond de la simulation.
La deuxième partie : contient des divers éléments optiques
1
2
1
Miroirs
3
1
4
1
4
1
5
1
6
1
7
1
8
1
9
1
10
1
11
1
12
1
13
1
1 :Miroir plan
2 :Lame semi-réfléchissante
3 :Miroir sphérique concave idéal
4 :Miroir sphérique convexe idéal
5 :Miroir sphérique concave réel
6 :Miroir sphérique convexe réel
7 : Miroir elliptique; parabolique; hyperbolique concave
8 : Miroir elliptique; parabolique; hyperbolique convexe
Surfaces absorbantes ou transparentes
9 : Ecran
10 : Diaphragme à iris
Les sources lumineuses
11 : Rayon unique
12 : Source ponctuelle
13 : Onde plane
Régions réfractantes
14 : Lentille mince convergente idéale
15: Lentille mince divergente idéale
16 : Lentille quelconque
17 : Polygône réfractant (dont: prisme, lame, etc...)
18 : Prisme réfractant
14
1
15
16
17
18
15
19
15
20
15
19 : Polycercle réfractant
20 : Sphère réfractante
Pour la 3ème partie
1 2 3 4 5 6 7
89
10
1112
1 : pour mesurer la distance ; 2 : pour mesurer les angles ; 3 : pour ajouter un texte sur le
dessin ; 4 : ajouter un trait une flèche…,5 : pour cacher des segments des rayons 6 : ajouter
(éditer) le commentaire de la simulation 7 : ajuter une œil stylisé 8 : ajouter un réseau
diffractant 9 : On peut demander à ce que les normales aux dioptres et aux miroirs soient
affichées 10 : On peut demander à ce que les angles d'incidence et de réfraction soient
affichés 11 : affiches les coordonnées des segments 12 : facteur de zoom.
Fonctionnement du logiciel
Remarque importante:
Un élément optique est repéré par au moins 2 points. Lors de la saisie de l'élément à la souris,
il ne faut pas maintenir le bouton de la souris enfoncé entre 2 points; pour un miroir plan par
exemple, on fait un clic simple à l'endroit où doit se situer le 1er bord du miroir, on relâche le
bouton, on va à l'endroit où doit se situer le 2ème bord, on clique et on relâche.
Déplacer un élément ou une source Cliquez sur le bouton "Déplacer"
dans la barre d'outil, ou passer par le menu "Edition" puis
"Déplacement d'un élément" . Il apparaît un certain nombre de cercles bleus, de croix vertes,
et éventuellement de croix cyan sur la simulation, autour des points caractéristiques des
éléments présents. Lorsqu'on passe le curseur de la souris au dessus de ces points, le curseur
change de forme, indiquant les opérations possibles. Il est ainsi possible de translater un
élément (croix verte), de faire bouger un point sans faire bouger les autres (cercles bleus) (le
curseur indique "rotation", bien que le terme soit impropre, le déplacement permettant aussi
une dilatation ou rétraction de l'élément), de déplacer un centre de courbure ou un foyer (croix
cyan).
La méthode est la suivante: lorsque le curseur a la forme désiré, on clique et on relâche; on
déplace la souris jusqu'à destination, on clique et on relâche; l'élément est redessiné "en
direct" au fur et à mesure du déplacement.
Cliquez sur le bouton "Propriétés" dans la barre d'outil, ou passer par le menu
"Edition" puis "Propriétés d'un élément" . Il apparaît un certain nombre de
cercles bleus sur la simulation, autour des points caractéristiques des éléments présents. Lorsqu'on
passe le curseur de la souris au dessus de ces points, le curseur change de forme, indiquant "Propriétés:
clic". Un clic simple lance alors l'ouverture de la fenêtre de propriétés de l'élément considéré. (c'est la
même fenêtre que lors d'un ajout d'élément par le menu "Ajout"). On valide les modifications dans la
fenêtre par le bouton "OK" ou on abandonne.
Important: une fois les modification effectuées, il faut cliquer sur le bouton "Fin prop." de la
barre d'outil pour revenir en mode normal.
Cliquez sur le bouton "Supprimer" dans la barre d'outil, ou passer par
le menu "Edition" puis "Suppression d'un élément" . Il apparait un
certain nombre de cercles rouges sur la simulation, autour des points caractéristiques des
éléments présents. Lorsqu'on passe le curseur de la souris au-dessus de ces points, le curseur
change de forme, prenant la forme d'un marteau. Un clic simple permet, après demande de
confirmation, de supprimer l'élément correspondant.
Une fois la suppression effectuée, le logiciel quitte automatiquement le mode suppression. Si
en fin de compte on ne veut rien supprimer, il faut cliquer sur le bouton "Fin suppr." dans la
barre d'outil.
Remarque : si on veut repartir d'une simulation vierge, passer par le menu "Fichier", puis
"Nouvelle simulation".
On peut grouper des éléments afin de pouvoir les translater ensemble.
- Premiére méthode: cliquer sur le bouton "Gr." de la barre d'outil; sur
chacun des éléments présents dans la simulation aparaît une croix violette; il suffit de cliquer
sur cette croix pour ajouter l'élément au groupe; une boîte de dialogue confirme l'ajout de
l'élément; une fois tous les éléments souhaités ajoutés, cliquer sur le bouton "Fin". Une boîte
de diaogue confirme la création du groupe.
- Deuxième méthode: menu "Edition" puis "Grouper des éléments" puis "Tous les éléments"
ou "Eléments à choisir". Dans le second cas, la saisie des éléments à ajouter se fait comme
dans la première méthode. Dans le premier cas, un groupe est créé qui contient tous les
éléments présents.
Déplacement d'un groupe: cliquer sur la bouton "Déplacer"; le groupe est représenté par une
croix verte et des lettres "Gr"; on peut alors le déplacer comme pour un élément classique. Ce
point est l'isobarycentre des points caractéristiques des éléments constitutifs du groupe.
Destruction d'un groupe: comme pour les autres éléments.
Cliquez sur le bouton "Dupliquer" dans la barre d'outil, ou passer par
le menu "Edition" puis "Dupliquer un élément" . Il apparait un certain
nombre de cercles bleus sur la simulation, autour des points caractéristiques des éléments
présents. Lorsqu'on passe le curseur de la souris au dessus de ces points, le curseur change de
forme. Un clic simple permet alors de dupliquer l'élément correspondant.
Une fois la duplication effectuée, le logiciel quitte automatiquement le mode duplication. Si
en fin de compte on ne veut rien dupliquer, il faut cliquer sur le bouton "Fin dupl." dans la
barre d'outil.
Annuler une opération en cours
Pour annuler l'opération en cours, appuyer sur la touche 'Esc' du clavier alors que le curseur
est au-dessus de l'espace de travail.
Annuler/Rétablir les dernières opérations
Les dernières opérations (à savoir: ajout ou suppression d'un élément, modification de ses
propriétés, déplacement, groupement, duplication) peuvent être annulées (jusqu'à 50 niveaux
d'annulation) au moyen de la combinaison de touche Ctrl+Z (ou: menu "Edition", "Annuler").
Et si en fait on ne voulait pas annuler (seuls les sots ne changent jamais d'avis !), on rétablit au
moyen de la combinaison de touche Ctrl+R (ou: menu "Edition", "Refaire").
Quelques application OptGeo
Cercle oculaire
Dans le cas d’un cercle oculaire tous les rayons issus d’un objet traversent les systèmes d’un
microscope puis vers l’œil
Principe de lunette Astronomique
Lunette astronomique est constituée de deux lentilles minces L1 et L2 portés par un axe
optique principal, la lentille L1 a une distance focale f1 et L2 a une distance focale f2.
La construction de l’image par lunette astronomique se fait par simulation OptGeo comme
indiqué sur la figure si dessous.
Principe d’un microscope
La construction d’une image par un microscope se fait par simulation OptGeoon portera deux
lentilles convergences puis le traçage des rayons issue d’un objet très petite comme des
cellules et des virus.
Le microscope est constitué de deux systèmes optiques sont l’objectif et l’oculaire ce dernière
est jouer le rôle d’une loupe.
La cas d’une Loupe
L’application de simulation OptGeo dans le cas d’une loupe est facile à réaliserpour les
différentes distances d’un objet avec le centre optique de la lentille convergente.
par exemple si OA<f on obtient l’image A’B’ virtuelle devant l’objet et plus grande que celuici.
Force d’agrandissement pour une loupe
La force d’agrandissement d’une
loupe est lier par l’œil et le type de
la loupe utilisé et son position par
apport à l’objet pour une œil
normale il a une distance minimale
de vision plus claire est égale 25cm.
Dans le cas de la figure ci-contre on
peut prendre le cas dans laquelle
l’œil est incompatible avec la loupe
donc l’image A’B’ obtenue est
construit à l’infini.
Dans le cas où l’objet situé devant le
foyer principale (OA=2*f) de la lentille on obtient une image réelle et inverse
Miroire Plane
La simulation
d’un
miroir
permet de
plan
comprendre le
principe
de
inverse de
retour
la lumière on
peut
prendre
plusieurs
application
dans
ce
sens.
Conclusion
L'intégration de logiciel OptGeo dans l’enseignement est l'un des importantes sur lequel se
penchent beaucoup de recherches en vue de produire des résultats plus reproductibles que
généralisables. Nous avons montré dans ce travail en quoi cette intégration permet de mettre
en place un environnement pédagogique orienté sur la construction de connaissances
concernant l’optique géométrique. Les résultats de l'expérience auxquels nous sommes arrivés
sont de nature à stimuler la réflexion en cours sur les modèles d'enseignement et
d'apprentissage et la réforme du système d'éducation et de formation.
En outre, ce travail nous a permis de comprendre la nature de la complexité de l'évaluation
des produits multimédias pédagogiques, et que la meilleure façon de s'assurer de l'intérêt
pédagogique d'un logiciel est de l'expérimenter auprès des utilisateurs potentiels.
Téléchargement