Telechargé par jalid.abdel

Tutorial Mecaplan

publicité
Initiation au logiciel Mécaplan-Wips v2.10
On utilise, comme support de travail, le schéma cinématique du mécanisme de bridage
pneumatique (voir les documents ci-joints). L’ordre des différents paragraphes de ce
document correspond à la démarche à adopter pour la création et la simulation d’un
mécanisme avec le logiciel Mécaplan-Wips.
1. PRESENTATION DE L’ECRAN PRINCIPAL
Barre d’outils
principale
Barre d’outils
secondaire
Menus déroulants
Limites de la
zone graphique
de travail
Touches de déplacement à
l’écran du cadre de travail
Ligne de message
pour l’utilisateur
Augmentation ou diminution
du facteur Zoom
Affichage coordonnées. On
bascule de cartésiennes en
polaires par la touche
Zone de saisie
des données au
clavier
Attention
Barre d’outils
de contraintes
Toute fonction en cours d’utilisation peut être interrompue par une action sur la
touche
.
Dans la suite des paragraphes, nous allons montrer pas à pas l’utilisation du logiciel pour
la schématisation cinématique et statique d’une partie seulement du dispositif de bridage.
2. INITIALISATION DES PARAMETRES
Ouverture de session : Pour créer un nouveau mécanisme, sélectionnez l’option Nouveau
du menu Fichier ou cliquez l’icône
principale.
de la barre d’outils
Remarque : Pour appeler un fichier existant, on sélectionnerait
l’option Ouvrir du menu Fichier ou on cliquerait l’icône
Sauvegarde :
de la barre d’outils principale.
Définissez le nom de votre fichier de travail à l’aide de la fonction
Enregistrer sous du menu déroulant Fichier. Sauvegardez votre
fichier sur votre disquette sous le nom « bride.wgf ». Ce nom
apparaît en haut de l’écran. Il sera dorénavant utilisé, par le logiciel,
1
D. MERTZ - MP-Wips.doc
à chaque sauvegarde de votre travail quand vous utiliserez la
fonction Enregistrer du menu déroulant Fichier ou que vous
cliquerez sur l’icône
Options générales :
de la barre d’outils principale.
de la barre
Pour définir les options de travail, cliquez l’icône
d’outils principale et exécutez les instructions ci-dessous :
Définissez le cadre de travail par l’option
feuille et en saisissant les limites suivantes :
Dévalidez l’affichage de la grille
Choisissez la couleur de fond que vous voulez
(noir ou blanc)
3. DEFINITION DE LA GEOMETRIE DU MECANISME
Nous nous contenterons, pour l’instant, de modéliser le
mécanisme ci-contre composé des seuls solides BATI et
BRIDE10.
Les dimensions sont données sur les documents joints.
BRIDE10
BATI
3.1.
Préparation des différents plans de travail
Sélectionnez l’icône « outils »
de la barre d’outils principale, puis l’icône « gestion
de la barre de menu secondaire. Exécutez ensuite, dans l’ordre, les
des plans »
instructions suivantes :
1. Tapez, sans blanc ni caractère spécial, le nom
du premier système encastré à créer : BATI
3. Choisissez ensuite une couleur en cliquant
sur la case Couleur.
4. Gardez le type de ligne CONTINU.
2. Cliquez sur la case Nouveau pour
valider la création de votre plan.
2
5. Pour affecter ces données au plan « BATI », sélectionnez
la ligne « BATI » de la fenêtre centrale (elle est alors
surlignée en bleu) et D.
cliquez
la case
Modifier.
MERTZ
- MP-Wips.doc
Attention
Pour chacun des systèmes encastrés (ou pièces) qui constitue le mécanisme, on aura
intérêt à prévoir un plan (ou niveau de travail) différent (bien qu’à la limite, pour Mécaplan-Wips,
toutes les pièces puissent être dessinées sur le même plan ou qu’une pièce puisse être partagée
sur plusieurs plans).
Chaque pièce est formée par le tracé d’un ensemble d’entités élémentaires (segments, arcs
de cercle,…). Ces ensembles d’entités doivent être regroupés sous forme de blocs pour qu’ils
puissent être reconnus comme pièces par Mécaplan-Wips (cf. § 3.5 et 4.1).
Créez encore le plan de travail correspondant au système encastré BRIDE10 avant de
quitter la fonction (en cliquant la case « OK »). Pour ce plan, choisissez une couleur
différente de celle du plan BATI.
3.2.
Tracé des pièces
Vous pouvez utilisez les fonctions du § 3.3 (zoom,…) et du § 3.4 (contraintes de tracé) en
même temps que les fonctions de tracé décrites ci-dessous.
Choix du plan de travail :
Placez-vous sur le plan (ou niveau de travail) « BATI ». Pour
cela, sélectionnez ce plan dans la « liste des plans »
de la barre d’outils principale.
Tracé du segment :
(0,0)
Sélectionnez la case « création d’objet »
d’outils principale.
de la barre
du menu secondaire qui
Sélectionnez la case « Ligne »
apparaît sous le menu principal.
Dans la zone de saisie des données en bas de l’écran,
(0,-20)
saisissez les coordonnées (0,-20 suivi de
) de l’origine du
segment, puis celle de sont extrémité (0,0 suivi de
)
Choix de la couleur
La couleur activée
apparaît ici
et du type de trait :
Si vous désirez,
changez de couleur
de trait, cliquez sur le
menu « choix de la
couleur courante »
Si vous désirez, changez
de type de trait, cliquez sur
le menu « liste des types
de lignes »
et faites votre choix
et
votre choix
faites
Remarque :
Lorsque l’option PLAN est sélectionnée dans le menu « liste des types
de lignes »
et dans le menu « choix de la couleur
courante »
de la barre principale de menu, les caractéristiques
du tracé sont celles que vous avez définies au moment de la création
du plan BATI.
Saisie des coordonnées :
Lorsqu’on entre des coordonnées au clavier, comme par
exemple pour le tracé du segment précédent, on a le choix
entre :
ª les coordonnées cartésiennes absolues mesurées par rapport
à l’origine fixe (0,0) de la feuille.
Exemple : 55,-16 où x=55mm et y=-16mm
3
D. MERTZ - MP-Wips.doc
ª les coordonnées polaires absolues mesurées par rapport à
l’origine fixe (0,0) de la feuille. Exemple : 32,<-15 (distance 32 mm de
l’origine et angle par rapport à l’horizontale –15°.
ª Les coordonnées cartésiennes relatives mesurées par rapport
au dernier point saisi (origine flottante).
Tracez les axes
dans une nouvelle
couleur et en trait
mixte fin
Exemple : @55,0 on se déplace horizontalement de 55mm
ª les coordonnées polaires relatives mesurées par rapport au
dernier point saisi (origine flottante).
Exemple : @30,<45 on se déplace à 45° par rapport à l’horizontale, sur
une longueur de 30mm.
Utilisez ces diverses possibilités pour tracer, à partir de
l’origine et en trait mixte fin (avec une nouvelle couleur), les
traits d’axes du bâti : axe horizontal de longueur 180mm et axe
vertical de longueur 50mm
Tracé du cercle :
Sélectionnez la case « Cercle par centre et rayon »
du
menu secondaire. Pensez à repassez en couleur et type de
trait « plan ».
Dans la ligne de dialogue, saisissez successivement les
) et la
coordonnées du centre du cercle (0,0 suivi de
valeur de son rayon (2.5 suivi de
)
Tracé du rectangle :
Sélectionnez la case « Rectangle »
du menu secondaire.
Dans la ligne de dialogue, saisissez successivement les
coordonnées des points situés sur la diagonale du rectangle
(-5,-20 suivi de
et 5,-25 suivi de
)
Hachurage:
Sélectionnez le menu « Outils »
de la barre d’outils
principale. Choisissez la case « Hachurage »
d’outils secondaire qui s’affiche.
de la barre
Sélectionnez le rectangle, puis cliquez sur la touche droite de
la souris pour arrêter la saisie des entités. Un menu apparaît
alors à l’écran. Indiquez un angle de hachurage de 45° et un
espace entre hachures de 1 mm.
3.3.
Utilitaires à utiliser conjointement aux autres fonctions
Modification des Sélectionnez la fonction « changement des attributs d’une entité »
attributs
d’une
entité :
du menu principal « Outils »
.
ª Changement de
Sélectionnez la ou les entités à modifier. Arrêtez la sélection avec la
plan
ª Changement de touche droite de la souris.
couleur
Sélectionnez le type de
ª Changement de La fenêtre ci-dessous apparaît :
paramètres à changer
type de trait
ª Changement
d’épaisseur
Définissez
la
nouvelle valeur
des paramètres
Validez vos choix
4
D. MERTZ - MP-Wips.doc
Pensez à utiliser les fonctions « zooms » disponibles dans le menu
Zoom :
« gestion de l’écran »
de la barre d’outils principale :
« Diminution du facteur zoom»
« Augmentation du facteur zoom»
« Zoom fenêtre »
« Zoom précédent ». Tous les
zooms sont mémorisés. On peut revenir au
« Zoom aux limites ». Ce sont les premier zoom.
limites de la fenêtre de travail définies dans
« Zoom étendu ». L’ensemble de
qui sont ce qui est tracé, même en dehors des
les « options générales »
affichées à l’écran.
limites du dessin, rempli au mieux l’écran.
« Donnez un point de passage de
« Panoramique ». Mécaplan
la
grille
»
déplace le tracé à l’écran, sans changer de
facteur de zoom. Désignez deux points à
l’écran pour définir le vecteur translation.
Effacement :
En cas d’erreur de tracé, il est possible d’effacer des entités en utilisant la
de la barre d’outils principale.
fonction « Effacer des entités »
Sélectionnez les entités à l’écran, puis cliquez sur la touche de droite de
la souris pour les effacer.
Rafraîchissement Après avoir utilisé certaines fonctions (effacement,…), rafraîchissez
d’écran :
de la barre d’outils
l’écran en utilisant la fonction « Redessine »
principale.
Sauvegardes :
Faites régulièrement des sauvegardes de votre travail, soit en utilisant
l’option Enregistrer du menu déroulant Fichier, Soit en cliquant sur
l’icône
3.4.
de la barre d’outils principale.
Utilisation du menu contraintes de tracé
Les contraintes de tracé sont des fonctions qui sont utilisées conjointement à d’autres
fonctions (tracé, découpe,…) pour servir de calage précis sur des points particuliers du
dessin.
Inactivation des contraintes
Contrainte « milieu »
Contrainte « extrémité »
Contrainte « intersection »
Contrainte « Centre »
Contrainte « perpendiculaire »
Contrainte « texte ». Calage sur le point
Contrainte « proximité ». Calage su le point le
origine d’un texte.
plus proche du curseur situé sur une entité
Contrainte « quadrant ». Calage sur l’un des
quatre points d’un cercle, aligné horizontalement ou
verticalement avec le centre du cercle
Contrainte « nodale ». Calage sur un point
(ou nœud) créé à l’aide de la fonction
Contrainte « grille »
Contrainte « orthogonale »
(calage horizontal ou vertical)
.
Nous allons utiliser le menu « Contraintes de tracé » pour notre exemple :
5
D. MERTZ - MP-Wips.doc
Le segment vertical du bâti dépasse dans le cercle, il faut le
découper.
Découpe d’une entité :
Sélectionnez la fonction « découpe d’entité »
⇒
principal « Outils »
du menu
.
L’entité à découper est le segment vertical, sélectionnez-le.
Pour désigner le point d’intersection du cercle et du segment
comme premier point de la coupure, cliquez sur la case
« Intersection »
du menu contraintes. Cliquez ensuite
successivement sur le segment et sur le cercle.
Dévalidez cette contrainte de tracé, soit en re-cliquant sur la
case
, soit en activant la case « Inactivation des
contraintes »
Pour désigner l’extrémité du segment (ou le centre du cercle)
comme deuxième point de coupure, cliquez sur la case
(ou la case « Centre »
« Extrémité »
à l’écran cette extrémité (ou ce centre).
) et désignez
Attention
Toute case activée du menu « Contraintes » apparaît « enfoncée » à l’écran. Les cases
fonctionnent comme des bascules : une case activée le reste jusqu’à ce qu’elle soit à
nouveau pointée. Plusieurs contraintes peuvent donc être utilisées simultanément.
ª Ces contraintes de tracé peuvent empêcher le bon fonctionnement d’autres
fonctions (création de chanfreins, de rectangles, de liaisons,…). On a donc intérêt à
inactiver les fonctions contraintes, dès qu’elles ne sont plus utiles, à l’aide de la
case
. La case de contrainte « grille »
et la case de contrainte « orthogonale »
3.5.
est activée/désactivée par la touche
par la touche
.
Création des blocs
Pour que Mécaplan-Wips puisse reconnaître en tant que pièce la partie de bâti qui a été
dessinée, nous allons grouper l’ensemble des entités en un bloc.
Création de blocs :
Point (0,0)
choisi pour
point de
base
Sélectionnez la fonction « Création d’un blocs »
du menu
principal « Tracé »
Indiquez le nom du bloc dans la ligne de saisie au bas de l’écran
(BATI suivi de
).
Désignez le point de base (ou point d’origine du groupe), soit par la
saisie de ses coordonnées (0,0 suivi de
), ou en le désignant à
l’écran en utilisant les possibilités des contraintes de tracé (contrainte
« Centre »
).
Encadrez ou pointez chacune des entités qui doit faire partie du
groupe BATI : cercle, segment, rectangle, hachure. Ne sélectionnez
pas les traits d’axe. Une fois la sélection terminée, validez le groupe
en cliquant avec la touche droite de la souris. Le nom « BATI »
apparaît alors dans la « liste des blocs »
6
BATI
du menu
D. MERTZ - MP-Wips.doc
Remarque :
Attention
Le point de base sera utilisé, par défaut par Mécaplan, comme centre de gravité de la
pièce BATI lors de la création de pièce (cf. § 4.1).
C’est au voisinage de ce point de base du bloc que Mécaplan indiquera à l’écran le
nom de la pièce (cf. § 4.3 ).
Les entités qui composent le bloc pourraient être situées sur plusieurs plans, mais
c’est à éviter. Gardez, comme règle, un pièce = un bloc = un plan (de même nom)
Modification d’un bloc :
Pour modifier un groupe, on peut utiliser les fonctions du menu
suivantes :
outils
(Voir davantage
d’explications au § 7.1)
« décomposition d’un bloc »
« ajout d’entités à un bloc. Il faut avoir au préalable
dessiné la ou les entités à ajouter.
« extraction d’entités d’un bloc ». N’efface pas l’entité,
mais la désolidarise du bloc.
3.6.
Fonctions complémentaires - Tracé de la pièce BRIDE10
Pour mettre en application tout ce qui a été vu précédemment et compléter l’utilisation du
logiciel par d’autres fonctions, on vous suggère la démarche suivante pour tracer la pièce
BRIDE10 (ce n’est pas forcément ici la démarche la plus simple !).
Placez vous sur le plan BRIDE10.
BRIDE10
Tracez le segment vertical :
Premier point : centre du cercle
Deuxième point : (0,34)
BATI
Effacez la partie de segment à l’intérieur du cercle
er
1 segment
2ème segment
BRIDE10
154,-13
BATI
En utilisant la contrainte de tracé « Orthogonale »
le début de chacun des segments ci-contre.
, tracez
Premier segment :
premier point ⇒ l’extrémité du segment vertical
deuxième point ⇒ cliquez n’importe où sur l’horizontale
Deuxième segment :
premier point ⇒ point (154,-13)
deuxième point ⇒ cliquez n’importe où sur la verticale
Chanfreins ou raccord de
Commencez par désactiver la contrainte « orthogonale »
si
deux segments :
elle est active et toutes les autres contraintes par la fonction
d’inactivation
.
Sélectionnez l’icône « Création d’un chanfrein »
BRIDE10
du
menu
Désignez successivement les deux segments à raccorder.
BATI
Donnez les valeurs des premier et deuxième écart du chanfrein
7
D. MERTZ - MP-Wips.doc
comme défini sur le schéma ci-après :
2nd écart
1er écart
Comme on raccorde ici les deux segments sans chanfrein,
répondre « 0 » pour les valeurs d’écarts.
Tracez un arc de cercle :
BRIDE10
Sélectionnez l’icône « Arc passant par 3 points »
du
menu
Désignez le premier point : (144,-8)
Désignez
le
deuxième
point :
Extrémité
du
segment
vertical
Désignez le troisième point : (164,-8)
BATI
Point de base
choisi
Pour terminer, créez un bloc « BRIDE10 » contenant l’ensemble
des entités liées à la bride 10. Sauvegardez votre fichier.
4. DEFINITION DU MECANISME
4.1.
Définition des pièces
Dans le menu déroulant Acquisition, sélectionnez la fonction Pièce, puis Ajouter.
Pour désigner, à Mécaplan, un bloc en tant que pièce, exécutez dans l’ordre les
instructions ci-dessous :
Regardez le numéro d’ordre
de la pièce. La pièce 1 doit
forcément être le bâti
Cliquez
ici,
puis
sélectionner à l’écran le
bloc qui doit composer la
1ère pièce (ici, le bloc BATI)
Remplacez le nom par
celui de la pièce : ici BATI
Cliquez sur cette case
pour mémoriser la
nouvelle pièce
Reprenez
les
étapes
précédentes pour créer la 2nd
pièce (BRIDE10), puis cliquez
sur Arrêt pour quitter la
fonction.
Attention
Remarque d’ordre général :
Si une fonction semble ne pas fonctionner correctement, cliquez n’importe ou à l’écran
avec la touche droite de la souris (ou appuyer sur la touche
) pour voir si une autre
fonction n’est pas encore en cours d’utilisation. Dans ce dernier cas une fenêtre s’affiche
et il faut cliquer sur la case « arrêt » pour quitter définitivement la fonction précédente. Le
message « pas de fonction en cours » doit apparaître dans la ligne de message.
8
D. MERTZ - MP-Wips.doc
Supprimer une pièce :
La fonction Pièce/Supprimer du menu déroulant Acquisition
permet d’annuler la déclaration d’un bloc en tant que pièce. Le
bloc dessin lui n’est bien sûr pas effacé.
La fonction Supprimer du menu déroulant Acquisition agit de la
même façon, mais est plus générale car elle autorise aussi la
suppression de liaisons.
Modifier une pièce :
L’activation de la fonction Pièce/Modifier du menu déroulant
Acquisition réaffiche la fenêtre de création de pièces précédente et
permet la modification de n’importe quel paramètre.
La fonction Modifier du menu déroulant Acquisition agit de la
même façon, mais est plus générale car elle autorise aussi la
modification de liaisons.
Sauvegarde
de
la Faites une sauvegarde de la définition de vos pièces en utilisant la
définition des pièces : fonction Sauvegarde du menu déroulant Acquisition.
4.2.
Définition des liaisons
Dans le menu déroulant Acquisition, sélectionnez la fonction Liaison, puis Ajouter.
Exécutez dans l’ordre les instructions ci-dessous :
Le nom de la liaison active apparaît ici.
Cliquez ici pour créer une articulation
entre les solides BATI et BRIDE10.
Le menu ci-dessous va apparaître
pour permettre de préciser les
caractéristiques de la liaison.
Cliquez sur cette case pour désigner
successivement la pièce 1 et la
pièce 2 qui participent à la liaison.
ou
Choisissez la pièce 1 qui participe
à la liaison dans la liste
déroulante
Si ce n’est déjà fait, sélectionnez
ici la pièce 2.
Saisissez ici les coordonnées du
centre de la liaison.
ou
Cliquez ici pour désigner à l’écran le
centre de la liaison (utilisez les fonctions
de la barre des contraintes)
Changez le nom de la liaison. Appelez-la
L10/0 pour rappeler qu’elle correspond au
mouvement de la bride 10 par rapport au
bâti 0 (il s’agit toujours du mouvement
de la pièce2 par rapport à la pièce1)
Cliquez sur « ajouter » pour que la liaison
soit mémorisée. Mécaplan propose alors la
création d’une nouvelle liaison.
9
Appuyez sur « Arrêt », puis sur « fin », pour
quitter la fonction de création de liaison
D. MERTZ - MP-Wips.doc
Attention
Dans la suite du TP, quand on parlera du mouvement dans une liaison, il s’agira forcément
du mouvement de la pièce déclarée en « pièce2 » par rapport à la pièce déclarée en
« Pièce1 » lors de la création de la liaison.
Pour les autres types de liaison (glissière, ponctuelle,…), la nature des paramètres demandés
lors de la définition de la liaison peut être différente de ceux présentés ici (voir annexe).
Supprimer une liaison : La fonction Liaison/Supprimer du menu déroulant Acquisition
permet d’annuler une liaison.
La fonction Supprimer du menu déroulant Acquisition agit de la
même façon, mais est plus générale car elle autorise aussi la
suppression de pièces.
Modifier une liaison :
L’activation de la fonction Liaison/Modifier du menu déroulant
Acquisition réaffiche la fenêtre de création de liaisons précédente
et permet la modification de n’importe quel paramètre.
La fonction Modifier du menu déroulant Acquisition agit de la
même façon, mais est plus générale car elle autorise aussi la
modification de pièces.
Sauvegarde
de
la Faites une sauvegarde de la définition de vos pièces en utilisant la
définition des liaisons : fonction Sauvegarde du menu déroulant Acquisition.
4.3.
Affichage des caractéristiques du mécanisme
Le logiciel fait apparaître la liaison articulation à l’écran sous la
forme de deux cercles concentriques.
ª des liaisons
On peut modifier l’affichage à l’aide de la fonction Symbolisation
ª des noms de liaisons
du menu déroulant Acquisition.
ª des noms de pièces
Visualisation à l’écran
Affichage, sur le dessin,
du symbole représentant la liaison
Affichage des noms de
pièces au voisinage de
leur centre de gravité.
Choix de la taille (en
mm) des symboles
affichés
Affichage des noms
des liaisons au voisinage de leur centre
Cliquez sur OK pour
valider la modification
des paramètres ou sur
Arrêt pour quitter sans
modifier
Choix de la taille (en
mm) des noms affichés
Informations
Modifiez le centre de gravité de la pièce BATI pour voir l’effet sur la
position d’affichage du nom BATI à l’écran. Reprenez ensuite les
valeurs initiales pour les coordonnées de ce centre de gravité.
Cette fonction Symbolisation n’affecte l’affichage des liaisons que
pour la phase de modélisation. Il existe une fonction identique dans
le menu déroulant Résultats qui permet l’affichage des liaisons (ou
pièces, ou…) pendant la phase d’exploitation des résultats (Cf. §6).
Pour obtenir à tout moment des informations sur les
caractéristiques des pièces ou des liaisons, sélectionnez le menu
Informations du menu déroulant Acquisition et pointez à l’écran
l’objet de la demande d’informations (pièces, liaisons,…). Pour une
information sur une liaison, il faut bien sûr que la visualisation des
liaisons soit validée pour qu’elle puisse être sélectionnée.
10
D. MERTZ - MP-Wips.doc
5. EXECUTION DU CALCUL
Attention
Le logiciel Mécaplan permet la simulation des mouvements d’un mécanisme. Il
fonctionne sur le même principe qu’un projecteur de caméra qui délivre 24 images à la
seconde, c’est-à-dire une image tous 1/24ème de seconde (cette valeur correspond, pour cet
exemple, à l’incrément de temps). Même si l’illusion de continuité du mouvement est bonne,
en réalité un nombre discret seulement de positions (ou images) du mécanisme est calculé.
La durée entre deux positions calculées par Mécaplan est appelée « Incrément ».
Elle est exprimée en secondes.
La durée totale entre la première position calculée et la dernière (ou amplitude du
mouvement) s’appelle « Débattement ». Elle est également exprimée en secondes.
On donne ci-dessous, la démarche pour définir les paramètres de calcul permettant la
simulation d’une rotation de un tour de la BRIDE10 par rapport au BATI, à la vitesse
de 1 tr/mn. Il y aura 60 positions calculées.
Pour lancer le calcul, sélectionnez la fonction Exécuter du menu déroulant Calcul.
Cette fenêtre d’information
apparaît en premier
4. Donnez, en secondes, la valeur
de l’incrément de temps entre
deux positions calculée
2. Choisissez la liaison qui
constitue la donnée (ou
l’entrée) du problème
3. Définissez le paramètre
de mouvement (vitesse de
rotation ici)
1. Cliquez sur « OK » pour
poursuivre le calcul ou sur
« Arrêt » pour l’abandonner
5. Définissez, en secondes,
l’amplitude du mouvement
6. Cliquez sur « Calcul » pour
lancer le calcul ou sur « Sortie »
pour abandonner le calcul
6. EXPLOITATION DES RESULTATS
6.1.
Simulation du mouvement
Ce menu permet de simuler le mouvement de n’importe quel ensemble de solides par
rapport à n’importe quel autre solide défini comme référence (et pas forcément le bâti).
Sélectionnez la fonction Mouvement/Simuler du menu déroulant Résultats. La fenêtre
ci-dessous apparaît :
11
D. MERTZ - MP-Wips.doc
4. Choisissez, parmi l’ensemble
des positions calculées, la position
de départ de la simulation
1. Désignez la ou les
pièces qui doivent bouger
pendant la simulation.
Cliquez le bouton droit de
la souris pour arrêter la
sélection. Par
défaut,
toutes les pièces seront
animées (mécanisme).
5. Visualisation de type :
ª dessin animé (avec
effacement des positions précédentes)
ª balayage de l’écran
(pas d’effacement des
positions précédentes)
2. Choisissez la pièce qui
sert de référence et qui
restera immobile à l’écran.
3. Sélectionnez le type de
visualisation :
ª Défilement continu
ª Arrêt image par image
6. Inversion possible du
sens de mouvement
7. Cliquez sur « OK » pour lancer
l’animation ou sur « Arrêt » pour quitter
la fonction
Pour accélérer ou ralentir l’animation, appuyez sur les touches « + » ou « - ». Pour
.
interrompre l’animation, utilisez la touche
Simulez d’abord un mouvement continu et testez les possibilités d’animation suivantes :
ª Essayez l’inversion de sens de mouvement.
ª Prenez la pièce BRIDE10 comme référence et observez l’animation du mécanisme.
Simulez ensuite un mouvement position par position et testez les possibilités
d’animation suivantes :
ª Changez de position de départ.
ª Visualisation avec effacement.
ª Visualisation sans effacement.
Pour ajouter à l’écran une position suivante, il faut tapez sur une touche quelconque.
Attention
Pour effacer ensuite les diverses positions affichées à l’écran, il faut :
ª d’abord quitter la fonction de simulation en appuyant sur la touche
. La fenêtre
de simulation de mouvement réapparaît. Cliquez sur la case « Arrêt ».
ª Sélectionner la fonction Mouvement/Effacer positions du menu déroulant
Résultats.
Remarque :
Les traits d’axe tracés dans le plan « BATI » n’ont pas été intégrés
au bloc « BATI », ils ne font pas partie de la pièce « BATI ». C’est pourquoi, si on choisit
la pièce «BRIDE10 » comme référence du mouvement, la pièce BATI tourne mais pas
les axes.
Tout ce qui n’est pas déclaré en tant que bloc-pièce au logiciel reste
toujours fixe à l’écran quel que soit sont plan de représentation .
6.2.
Etude des trajectoires – Vecteur position d’un point
Construisez la trajectoire du point de coordonnées (154,-13) de la pièce BRIDE10 dans
le BATI. Pour cela, activez la fonction Trajectoire/Afficher du menu déroulant Résultats.
12
D. MERTZ - MP-Wips.doc
Au lancement de la commande, MECAPLAN demande de préciser le point pour lequel on
cherche la trajectoire. Une fois le point réticulé (ou ses coordonnées entrées au clavier), la
fenêtre de dialogue ci-dessous s'affiche à l'écran. Saisissez les paramètres requis
(instructions 1 à 3 ci-dessous).
1. Choisissez la référence
du mouvement en désignant
une pièce à l’écran
ou
1. Choisissez la référence
du mouvement dans la liste
déroulante
4. Entrez
les
coordonnées du
point ou Saisir à
l’écran le point
dont on cherche la
trajec-toire
3. Cliquez sur « OK » pour valider les
paramètres et exécuter le tracé de
trajectoire ou cliquez sur « Arrêt »
pour abandonner la fonction
2. Choisissez, dans la liste
déroulante, la pièce à
laquelle appartient le point
dont on cherche la trajectoire
ou
2. Désignez à l’écran la pièce
à laquelle appartient le point
dont on cherche la trajectoire
La trajectoire recherchée est tracée à l’écran en
superposition du mécanisme.
ª Appuyez n’importe qu’elle touche, Mécaplan
affiche, dans la ligne de message, les positions
successives des points de la trajectoire.
Une action sur les touches
, ou sur la
,
touche droite de la souris réaffiche la fenêtre de création
de trajectoire. Vous pouvez alors :
Ajouter une autre trajectoire au tracé à l’écran.
Changez la valeur des paramètres de trajectoire
(instructions 1, 2, 4, puis 3 ci-dessus)
ª cliquer sur la case « Arrêt » pour abandonner la
fonction « Trajectoire ».
ª
Remarque :
ª Pensez à faire un « zoom étendu » si la trajectoire sort de l’écran.
ª Même si la trajectoire ressemble à un cercle, il s’agit en fait d’un ensemble de segments qui
relient les différentes positions calculées qu’occupe le point (154,-13) de BRIDE10 dans le BATI.
Si on avait exécuté un calcul avec un incrément de 15 s (4 positions calculées seulement) cette
trajectoire circulaire aurait été représentée par un carré ! ! !
ª Dès que vous pensez en avoir terminé avec la fonction de tracé de trajectoire, quittez cette
fonction en sélectionnant la case « Arrêt » de la fenêtre de saisie des paramètres de trajectoire.
Faites-le en l’occurrence avant d’utiliser n’importe laquelle des fonctions ci-après.
Positions des points de
la trajectoire :
Sélectionnez la fonction Trajectoire/Consulter du menu déroulant
Résultats.
Vous pouvez cliquez au voisinage d’un point de la trajectoire.
Mécaplan affiche, dans la ligne de message, les coordonnées du
point calculé de la trajectoire le plus proche. Un curseur en forme
de croix apparaît à l’endroit du point détecté.
Vous pouvez aussi appuyer sur n’importe quelle touche du clavier
pour passer au point calculé suivant de la trajectoire.
13
D. MERTZ - MP-Wips.doc
Sélectionnez la fonction Trajectoire/Lister du menu déroulant
Résultats.
Impression des
résultats :
Désignez à l’écran la trajectoire dont vous voulez afficher les
caractéristiques. La fenêtre suivante apparaît alors :
Cliquez sur une ligne de
la
liste.
La
ligne
concernée est alors
surlignée en bleu. En
même temps un carré
apparaît sur la courbe
pour marquer la position
du point considéré.
Cliquez, avec la touche
gauche, de la souris au
voisinage de la courbe.
Un carré apparaît sur
la courbe sur le point
calculé le plus proche.
En même temps les
coordonnées de ce
point sont surlignées
en bleu dans le cadre
de gauche
Valeurs mini, maxi et
moyenne de l’ordonnée
de la courbe
Le nom inscrit ici apparaîtra automatiquement
sur
les
documents
imprimés, en plus de la
date et de l’heure
d’impression.
Il correspond au nom de
la personne qui produit
le document.
Si on cliquait, à l’intérieure de cette fenêtre graphique, avec la
touche de droite de la souris, on ferait apparaître une fenêtre
supplémentaire de dialogue qui autoriserait :
ª la sauvegarde dans un fichier ou l’impression des données
ª la copie en mémoire tampon (pour insertion dans un document
word par exemple) ou l’impression de cette courbe.
Inclusion de trajectoire : Inclure une trajectoire, c’est insérer l’ensemble des segments qui
simulent cette trajectoire dans le bloc qui définit la pièce de
référence du mouvement étudié.
Attention
Sélectionnez la fonction Trajectoire/Inclure du menu déroulant
Résultats. Sélectionnez la trajectoire tracée précédemment pour
l’inclure au solide BATI.
Remarque :
ª La trajectoire fait dorénavant partie intégrante du bloc BATI.
ª Elle est tracée sur le plan et dans le style de trait qui
étaient actifs au moment de la création de la trajectoire
(vraisemblablement en ligne continue et sur le plan
« BRIDE10 »).
ª On n’a pas le choix de la couleur de la trajectoire incluse.
Elle ne peut qu’être identique à la couleur de type « plan »
attachée au plan sur lequel elle a été crée.
On désire tracer et inclure une nouvelle trajectoire (celle du point
0,34 du solide BRIDE10 dans le BATI). On veut que cette
trajectoire soit incluse sur le plan « BATI » et non pas sur le plan
BRIDE10, et qu’elle soit tracée, en pointillés. Faites-le.
Effacement d’une
trajectoire :
Sélectionnez la fonction Trajectoire/Effacer du menu déroulant
Résultats pour effacer les trajectoires de votre choix (sauf les
trajectoires incluses).
Sélectionnez la fonction Trajectoire/R.A.Z du menu déroulant
Résultats pour effacer en une seule opération toutes les
trajectoires tracées à l’écran (sauf les trajectoires incluses)
14
D. MERTZ - MP-Wips.doc
6.3.
Etude des positions, vitesses ou accélération d’un point quelconque
Vitesses et
accélérations d’un
point quelconque du
mécanisme
Le mouvement que l’on veut étudier est défini lors de la création de la
trajectoire du point concerné (comme indiqué dans le § 6.2).
On sélectionne ensuite la fonction Vitesse/accélération du menu
Trajectoire. Sélectionnez la trajectoire qui vous intéresse (elle ne
doit pas avoir été incluse). La fenêtre suivante s’affiche alors :
1. Choisissez
le
type
de
paramètre de vitesse que vous
voulez afficher.
Composantes
des
vitesses ou accélérations du point dans la
G G
base générale ( x, y )
liée à l’écran
ou
1. Choisissez
le
type
de
paramètre d’accélération que
vous voulez afficher.
2. Cliquez ici si vous
voulez une représentation sous forme de
courbe (avec le temps
en abscisse)
2. Cliquez ici si vous voulez une
représentation sous forme de
champ de vecteurs directement
tracés sur la trajectoire du
mécanisme
3. Validez le choix par
« OK »
z
Le type de visualisation « courbe » conduit au même type de
représentation graphique qu’à la page 14.
z
Si le mode Champ est réquisitionné, les résultats s’affichent à
l’écran sous forme de champ de vecteurs.
Par exemple, si l’option « projection/x »
des
vitesses
est
demandée,
la
représentation ci-contre est donnée :
Composantes Vx des vecteurs vitesse
ª les touches « + » et « - » permettent d’allonger ou de raccourcir la taille de la
représentation des vecteurs à l’écran.
ª les coordonnés d’un point de la trajectoire ainsi que la valeur du paramètre de
mouvement associé (Vx, Vy,…) apparaissent dans la ligne de message en bas
d’écran.
ª Les touches « P » et « S » permettent de passer au point précédent ou suivant
sur la trajectoire. On peut aussi désigner à la souris n’importe quel point de la
trajectoire.
, la touche « T » ou la touche « Q » permettent de revenir à
ª La touche
la fenêtre de choix des paramètres à représenter.
Vérifiez, sur notre exemple, les résultats donnés par Mécaplan.
6.4.
Mouvements relatifs dans une liaison (position ou torseur cinématique)
L’option « relative » de la fonction Courbe du menu déroulant Résultats, présentée dans
ce paragraphe, est utilisée lorsque l’on recherche les caractéristiques du torseur cinématique
de liaison entre deux solides. Il donne aussi, à chaque instant, les positions relatives entre
les solides liés par une liaison.
15
D. MERTZ - MP-Wips.doc
Attention
Pour ne pas faire d’erreur d’interprétations dans les résultats fournis par Mécaplan,
il faut comprendre parfaitement comment sont définis les différents repères liés à
une liaison.
On ne donne ci-dessous que l’exemple de l’articulation que nous avons étudié (pour les
autres liaisons, voir l’annexe).
G
G
G
G
G
y 10
G
y0
y 10 = y 0 = y
x10
BRIDE10
BRIDE10
Angle noté « a1 » (degré)
G
y
C10=C0
G
G
G
x10 = x0 = x
BATI
G
y
G
x0
C10=C0
BATI
Attention
G
x
G
x
POSITION DE REFERENCE
Quand Mécaplan parle de vitesses (ou positions)
relatives, il s’agit toujours du mouvement de la
pièce 2 par rapport à la pièce 1 de la liaison.
Les pièces 1 et 2 sont définies lors de la
création de la liaison. Nous avions défini
précédemment :
ª Pièce 1 = « BATI »
ª Pièce 2 = « BIELLE10 »
POSITION APRES MOUVEMENT RELATIF
G G
( x, y ) est la base générale liée à l’écran
Repères idéaux attachés à la liaison :
G G
ª (C0 , x 0 , y 0 ) repère lié à la pièce BATI
G G
ª (C10 , x10 , y10 ) repère lié à la pièce BRIDE10
G
G G
On note a1 = ( x 0 , x10 ) angle orienté mesuré sur z 0 .
G G G
Mécaplan donne les résultats suivants, dans la base idéale ( x 0 , y 0 , z 0 ) liée à la pièce 1 :
G
ª L’angle a1 (en degrés) et sa dérivée a (vitesse de rotation en tr/mn) mesurés sur z 0
G
G
ª Les composantes du déplacement relatif dans la liaison d1 = C 0 C10 .x 0 et d 2 = C 0 C10 .y 0
du centre C10 lié à la pièce 2 (BRIDE10) par rapport à la pièce 1 (BATI)
G
G
G
G
ª les composantes de vitesses V1 = V(C 10 ,10 / 0).x 0 et V2 = V (C 10 ,10 / 0).y 0 du centre C10
G
lié à la pièce 2 (BRIDE10) par rapport à la pièce 1 (BATI) et la norme V = V(C10 ,10 / 0)
(d1, d2, V1, V2 et V sont bien sûr toujours nuls pour une articulation)
Torseur cinématique Sélectionnez la fonction Courbe du menu déroulant Résultats.
Choisissez ensuite le type de résultats à afficher comme indiqué cide liaison
dessous.
L’option « relative »
Position relative des
donne la position
solides dans une
relative des solides
liaison :
dans une liaison
entre deux solides.
Non pris en compte
pour l’étude d’une
vitesse
ou
d’un
déplacement
« relatif »
Choix de la liaison
dont on cherche les
caractéristiques
de
vitesse ou de position
L’option « relative »
donne le torseur
cinématique
du
dans
mouvement
une liaison entre
deux solides.
En cliquant la case « OK », la fenêtre suivante apparaît :
16
D. MERTZ - MP-Wips.doc
Coordonnées, dans la
position de référence et
dans la base générale
G G
( x, y ) , des vecteurs de
G G
la base idéale ( X i , Yi )
liée au solide 1 de la
liaison. Pour nous :
G G
G G
Xi = x0 et Yi = y0
Cliquez sur une de
ces 4 courbes pour
la faire apparaître
sous la forme d’une
fenêtre graphique
comme
à
la
page 14.
Vérifiez, sur notre exemple, les résultats donnés par Mécaplan.
6.5.
Mouvements relatifs de deux solides quelconques (torseurs cinématiques et
positions relatives)
Attention
L’option « absolue » de la fonction Courbe du menu déroulant Résultats, présentée
dans ce paragraphe, est utilisée lorsque l’on recherche les caractéristiques du torseur
cinématique d’un mouvement entre deux solides qui ne présentent aucune liaison entre
eux. Il donne aussi, à chaque instant, les positions relatives entre ces solides.
Pour ne pas faire d’erreur d’interprétations dans les résultats fournis par Mécaplan,
il faut comprendre parfaitement comment sont définis les différents repères liés à
une pièce :
G G
ª A chaque solide Si, Mécaplan lie un repère (G i , x i , y i ) .
ª Gi est le centre de gravité du solide Si.
G
G
ª Les directions x i et y i , liées au solide Si, sont telles que, dans la position de
G
G
G
G
référence, ∀S i , x i = x et y i = y .
On donne, ci-dessous, l’exemple de l’articulation que nous avons étudié :
G
G
y0 = y
G
y0
G
G
y 10 = y
BRIDE10
G10
BRIDE10
G0
G
y
G
x
G
G
x0 = x
G
y 10
G10
G
G
x 10 = x
BATI
POSITION DE REFERENCE
G G
( x, y ) est la base générale liée à l’écran
G
y
G
x0
G0
G
x
G
x10
BATI
POSITION APRES MOUVEMENT RELATIF
G
G G
On note a = ( x 0 , x10 ) angle orienté mesuré sur z 0
Le terme d’« absolue » utilisé par le logiciel est ambigu. Sous ce vocabulaire, Mécaplan
calcule, pour le mouvement d’un solide Sk (pièce sélection) par rapport à un autre solide Si
(pièce référence), les paramètres suivants :
17
D. MERTZ - MP-Wips.doc
G G
G G
L’angle de rotation « a » (en degrés) de la base ( x k , y k ) par rapport à la base ( x i , y i )
G
et sa dérivée notée « z » (vitesse de rotation en tr/mn) mesurés sur zi
G G
ª Les composantes, dans la base ( x i , y i ) liée au solide Si, du vecteur position G i G k :
G
G
G x = G i G k .x i et G y = G i G k .y i et la norme G i G k
G
G
G
ª les composantes du vecteur vitesse V(G k , S k / S i ) : V x = V(G k , S k / S i ).x i et
G
G
G
Vy = V(G k , S k / S i ).y i et la norme V = V(G k , S k / S i )
ª
Torseur cinématique Sélectionnez la fonction Courbe du menu déroulant Résultats.
Choisissez ensuite le type de résultats à afficher comme indiqué cid’un mouvement
dessous.
Position d’un centre
de gravité
N’utilisez pas la
liste déroulante pour
sélectionner la pièce
de référence (erreur de
1. L’option « absolue »
donne la position de la
pièce
« sélection »
par rapport à la pièce
« référence »
programmation du logiciel)
2. Choix de la Pièce
servant de référence
au mouvement
1. L’option « absolue »
donne
le
torseur
cinématique du mouvement de la pièce
« sélection »
par
rapport à la pièce «
référence »
3. Choix de la Pièce
dont on cherche les
caractéristiques
de
vitesse ou de position
En cliquant sur la case « OK », Mécaplan affiche une fenêtre
graphique comme celle de la page 14. Toutes les remarques faites au
sujet du tracé de courbe restent valables (cf. page 14).
Attention
Vérifiez, sur notre exemple, les résultats donnés par Mécaplan.
Même si cela est possible, il faut éviter d’utiliser les menus « position absolue » ou
« vitesse absolue » pour une référence du mouvement autre que la pièce 1 déclarée au
logiciel (le BATI pour nous). Les courbes Gx(t), Gy(t), Vx(t) et Vy(t) données par le logiciel
risquent, en effet, d’être perturbées numériquement et nécessite du « doigté » pour
être interprétées.
Position d’un centre Même démarche et mêmes remarques que précédemment, mais on
choisit l’option « centre » du menu « position ». Mécaplan donne la
de liaison
position d’un centre de liaison par rapport à une pièce de référence.
Représentation d’une Sélectionnez la fonction Courbe du menu déroulant Résultats. Mais
activez cette fois la case « A la carte », de la fenêtre de sélection.
courbe quelconque
Cette option laisse le choix des variables à mettre en abscisse et en
ordonnée pour la représentation des courbes.
Remarque :
ª Les variables qualifiées d’« absolues » sont toujours calculées pour le
mouvement du solide sélectionné par rapport à la pièce 1 du mécanisme (le BATI
pour nous) et dans le repère lié à cette dernière. Les vitesses sont calculées au
centre de gravité de la pièce sélectionnée.
18
D. MERTZ - MP-Wips.doc
ª Les variables qualifiées de « relatives » correspondent au mouvement de la
pièce 2 par rapport à la pièce 1 d’une liaison et sont exprimées dans la base liée
à cette dernière pièce. Les vitesses sont calculées au centre de la liaison.
ª Pour pouvoir saisir une liaison à l’écran, il faut que son symbole apparaisse à
l’écran (voir affichage des symboles ci-après)
3. Saisissez à l’écran la
pièce ou la liaison qui doit
servir à définir la variable
en ordonnée de la courbe
1. Saisissez à l’écran
la pièce ou la liaison
qui doit servir à définir
la
variable
en
abscisse de la courbe
4. Cliquez, dans cette
fenêtre sur la variable à
afficher en ordonnée
2. Cliquez, dans cette
fenêtre sur la variable
à afficher en abscisse
Tracez la composante de vitesse Vx du point désigné comme centre
de gravité du solide BRIDE10 en fonction de la position angulaire de
ce même solide dans le repère lié au BATI.
Visualisation à l’écran On peut modifier l’affichage à l’aide de la fonction Symbolisation du
menu déroulant Résultats.
ª des liaisons
ª des
noms
de Cette fonction est identique à celle du § 4.3. page 10, mais elle
n’affecte l’affichage des caractéristiques du mécanisme que pendant
liaisons
ª des
noms
de la phase d’exploitation des résultats.
pièces
Il est important d’afficher les liaisons dans le cas où l’on voudrait
pouvoir les sélectionner directement à l’écran.
7. APPLICATION AU SYSTEME DE BRIDAGE PNEUMATIQUE
Nous allons appliquer tout ce qui a été vu précédemment à l’étude cinématique du
système complet de bridage pneumatique. Nous allons en profiter pour apprendre d’autres
fonctions utiles de Mécaplan-Wips.
Voir les documents annexes qui donnent les caractéristiques du système de bridage
pneumatique
7.1. Modification de la géométrie du mécanisme
On donne ci-après le schéma cinématique minimal du système de bridage pneumatique.
Ce schéma sera à reproduire à l’aide de l’environnement graphique de Mécaplan-Wips.
Plutôt que de redessiner tout le mécanisme, nous allons modifier et compléter la partie
de mécanisme tracée précédemment.
19
D. MERTZ - MP-Wips.doc
G
y
BIELLETTE5
B
BRIDE10
A
COULISSEAU3
C
E
G
x
Do
D"
D’
D
BATI
On donne :
G
G
CB = 34 y
G
G
G
CA = −35 x + 27 y
G
G
G
CD = −154 x − 13 y
G
G
G
CE = −35 x + 2 y
TIGE14
G
G
G
CH = −34 y − 172 y
G
G
G
DD" = 10 x + 5 y
G
G
G
DD" = −10 x + 5 y
G
G
DD 0 = 15 y
Attention
H
Avant chaque transformation importante du mécanisme par l’une des fonctions
décrites ci-dessous, il est fortement conseillé de faire une sauvegarde de votre
travail. En effet, aucune annulation de fonction n’est disponible.
Extraction
bloc
d’entités
d’un On veut supprimer les trajectoires qui ont été incluses
précédemment à la pièce BATI. Pour cela, il faut procéder en
deux étapes :
ª
BRIDE10
du menu principal « Outils »
. Désignez d’abord le
bloc à modifier (le BATI), puis les entités à extraire du bloc (les
trajectoires). Arrêtez la sélection et validez avec la touche droite
de la souris.
ª
BATI
Sélectionnez la fonction « suppression d’entités d’un bloc »
Les trajectoires ne font plus partie du bloc BATI, on peut
maintenant les effacer avec la fonction « effacer »
.
Vérifiez, en lançant la simulation du mouvement du mécanisme,
qu’il est inutile de relancer le calcul lorsqu’on modifie
graphiquement de cette façon un bloc qui compose une pièce.
20
D. MERTZ - MP-Wips.doc
Décomposition d’un bloc :
BRIDE10
BATI
Nous allons modifier la pièce BRIDE10 comme sur le schéma cicontre :
ª
Il nous faut d’abord éclater le bloc BRIDE10. Sélectionnez la
fonction « décomposition d’un bloc »
du menu principal
« outils »
et désignez le bloc BRIDE10. Arrêtez la sélection
par un clic droit de la souris.
Placez-vous ensuite sur le plan BRIDE10. Vous pouvez alors
tracer le cercle (rayon 2.5mm) et découpez les segments de la
pièce BRIDE10.
ª
Purge d’un bloc non utilisé Le nom BRIDE10 a été utilisé précédemment pour un bloc qui
est maintenant décomposé (et qui n’existe plus en tant que tel)
Essayez de reformer ce bloc, sous le nom BRIDE10, en
regroupant l’ensemble des entités du plan BRIDE10 (Cf. § 3.5)
⇒ Mécaplan refuse de le faire car il ne peut pas utiliser un nom de
bloc qui existe déjà. Le bloc BRIDE 10 est devenu inutilisable.
Pour détruire les noms de blocs inutilisés, sélectionnez la
fonction « Purge »
du menu principal « outils »
fenêtre suivante apparaît :
3. Sélectionnez le bloc
inutilisé à effacer
. La
4. cliquez ici pour faire
passer le bloc BRIDE10
dans la colonne de
droite des objets à
purger
1. Sélectionner le type
d’éléments à purger
Fenêtre de visualisation
de l’élément à purger
2. Cochez cette case
pour visualiser, après
sélection, l’ancien bloc
à effacer
5. Cliquez ici pour
valider la purge. Puis
quittez la fonction par
la case « Fin »
Vous pouvez maintenant réutiliser le nom « BRIDE10 » pour
reformer le bloc qui regroupe l’ensemble des entités liées à la
bride 10. Faites-le.
Remarque :
Le fait d’avoir purger le bloc BRIDE10 a annuler
automatiquement la déclaration des pièces et des liaisons
du mécanisme (même effet que la fonction Initialisation du
menu déroulant Acquisition). Toute la modélisation du
mécanisme sera à reprendre depuis le début.
21
D. MERTZ - MP-Wips.doc
Duplication par insertion Nous allons tracer la liaison pivot glissant entre le bâti et la tige
de vérin 14 en nous aidant du bloc BATI déjà dessiné.
d’un bloc :
, puis le bloc BATI dans la
Sélectionnez le menu « tracé »
Bloc BATI
au point 0,0
« liste des blocs »
BATI
du menu secondaire.
Sélectionnez la fonction « insertion d’un bloc »
secondaire pour dupliquer le groupe BATI.
Bloc dupliqué au
point –35,-150
du menu
Donnez le point d’insertion du nouveau bloc : -35,-150
Ce type de duplication ne s’applique qu’à des blocs.
Nous allons faire subir une rotation de 90° au bloc dupliqué.
Rotation d’entités :
Sélectionnez la fonction « Rotation »
90°
« transformations »
du menu principal
.
Sélectionnez l’ensemble des entités qui doivent subir la rotation
et cliquez la touche droite de la souris pour arrêter la sélection.
Donnez enfin l’angle de rotation (90°).
Dupication d’entités
translation ou copie :
par 1. Transformation du symbole de liaison pivot en pivot glissant :
Effacez le cercle de la liaison pivot tracée précédemment.
Tracez le premier segment de la liaison pivot glissant (premier
Liaison dupliquée
par translation
point : -32.5,-145 ; second point : @0,-10)
Sélectionnez la fonction « Translation multiple »
principal « transformations »
du menu
.:
ª Donnez le nombre de copies (2 pour dupliquer une entité une
seule fois).
ª Sélectionnez le segment qui vient d’être tracé et cliquez
155 mm
la touche droite de la souris pour arrêter la saisie.
ª Donnez les points qui définissent la translation : premier
point (n’importe lequel) et le deuxième point (en coordonnées relatives :
@-5,0).
2. Dupliquez le symbole de la liaison pivot glissant :
5 mm
Utilisez une nouvelle fois la fonction « Translation multiple »
pour dupliquer l’ensemble de cette liaison pivot glissant en la
déplaçant de 155 mm le long de l’axe des y.
Segment à créer et à
dupliquer par translation
de 5 mm vers la gauche
Remarque :
ª
la fonction « copies multiples »
se distingue de la
en ce sens que les
fonction « translation multiple »
différents vecteurs translation peuvent être définis entre
chaque duplication.
Ces types de duplication s’appliquent aussi bien à
des blocs qu’à des ensembles d’entités non groupées
en bloc.
ª
22
D. MERTZ - MP-Wips.doc
On veut modifier, par une symétrie, la position du bâti dans la
liaison pivot glissant entre le coulisseau 3 et le bâti (voir le
schéma ci-contre).
Symétrie :
Axe de symétrie
Non représenté
du menu principal
Sélectionnez la fonction « Miroir »
« transformations »
.
Désignez à l’écran l’ensemble des entités qui doivent subir la
transformation et terminez la saisie en cliquant le bouton droit de
la souris.
Définissez l’axe de symétrie par deux points (1er point : -35,0 ;
2nd point : -35,20 ; si l’axe existait à l’écran, on aurait pu pointez
ses deux extrémités).
Ajout d’entités à un bloc :
Ajoutez l’ensemble des entités nouvellement tracées sur le plan
BATI dans le bloc BATI.
Pour cela, sélectionnez la fonction « Ajout d’entités à un bloc »
du menu principal « Outils »
Ajout au
groupe
.
Désignez d’abord le bloc à modifier (BATI), puis l’ensemble des
entités à ajouter à ce bloc. Arrêtez la sélection et validez avec la
touche droite de la souris.
Appliquez tout ce qui vient d’être vu pour compléter le tracé du schéma cinématique du
mécanisme qui a été donné précédemmment.
Résumé du travail à faire :
Créez les plans BIELLETTE5, COULISSEAU3, TIGE14 affecté à chacun des solides
à tracer.
ª Dessinez les pièces. Chaque pièce est dessinée sur le plan qui porte le même nom
(un plan = une pièce).
ª Groupez les entités liées à une même pièce dans un bloc qui porte le même nom que
la pièce et le plan qui lui est affecté (un bloc = un plan = une pièce)
ª
Pensez à :
Faire des sauvegardes régulières
Désactiver les contraintes de tracé dès qu’elles ne sont plus utiles
Vérifier que vous avez bien quittez une fonction avant d’en utiliser une autre (lisez le
message en bas de l’écran ; sortez d’une fonction par la case « Arrêt »)
ª
ª
ª
7.2.
Travail demandé
Vous avez un compte rendu de TP à rédiger. Toutes les questions auxquelles vous
devez donner une réponse se trouvent dans le texte qui vous a été remis individuellement et
que vous pouvez conserver.
Suivez scrupuleusement les indications données dans ce texte. N’hésitez pas non plus à
utiliser la présente notice pour retrouver les principales règles à connaître concernant
l’exécution du dessin du mécanisme, la création des liaisons, la définition des paramètres de
calcul et l’exploitation des résultats.
23
D. MERTZ - MP-Wips.doc
Reproduisez sur votre feuille de copie le schéma cinématique minimal du
mécanisme donné page 20. Vous reporterez sur ce schéma, toutes les données utiles à la
rédaction de votre comte rendu de TP (noms des pièces, caractéristiques des liaisons,
coordonnées des points, …)
Création des liaisons du mécanisme - Paramètres de calcul
Mécaplan ne permet de traiter que les problèmes plans. C’est-à-dire les problèmes pour
lesquels le vecteur vitesse de n’importe quel point du mécanisme reste parallèle au plan
G
G G
( x, y ) et que le vecteur rotation des solides reste parallèle au vecteur z .
Pour chacune des liaisons réelles (spatiales) entre solides du mécanisme, précisez le
type de liaison (planes) à déclarer pour Mécaplan. Donnez les caractéristiques de ces
liaisons.
On baptisera Li/j la liaison entre un solide i et un solide j. Déclarez au logiciel l’ensemble
des liaisons du mécanisme.
7.3.
On ne s’intéresse qu’à la phase de desserrage de la bride. On donne les caract.
Liaison d’entrée
Paramètres de calcul
7.4.
Exploitation des résultats cinématiques
liste des questions posées
24
D. MERTZ - MP-Wips.doc
8. ETUDE DES ACTIONS MECANIQUES
8.1. Description des actions mécaniques extérieures à un mécanisme
Attention
Nous allons dans un premier temps aborder la façon de modéliser les actions
mécaniques pour le logiciel Mécaplan-Wips.
Seules les actions mécaniques qui agissent de l’extérieur sur un système
mécanique sont à déclarer au logiciel. Les inconnues d’actions de liaison entre
deux solides du mécanisme sont automatiquement définies à partir du moment où
le type de liaison à été déclarée au logiciel.
Définition d’une
mécanique
action
Fixe - Constant
Choisir
le
type
d’action mécanique
désirée
Termes à connaître pour le choix d’un type d’action :
Connu / Inconnu :
•
Une action mécanique est de type « Connu » si elle
constitue une donnée du problème.
•
Une action mécanique est de type « Inconnu » si elle
correspond à une action susceptible de varier au cours du
mouvement et qu’elle ne constitue pas une donnée.
Les actions « Inconnu »
Constant / Variable :
Les actions « Variable »
•
Une action est dite « Constante » si les modules de sa
résultante et de son moment restent constants au cours du
temps. Le direction de la résultante peut varier par rapport
G G
aux directions générale ( x, y) liées à l’écran.
•
Une action est dite « Variable » s’il s’agit d’une action
connue et que le module de sa résultante ou de son moment
ne reste pas constant au cours du temps. La variation de
l’intensité de cette action est donnée, pour le débattement de
calcul, au choix, soit en fonction du temps ou en fonction du
paramètre de mouvement d’une liaison. On peut se donner
la variation de l’intensité de l’action sous forme de courbe, de
tableau de valeurs (à partir d’une équation), ou la définir
sous forme de polyligne.
24
D. MERTZ - MP-Wips.doc
Fixe / Lié pièce :
•
une action est dite « Fixe » si elle garde une direction fixe
G G
par rapport aux directions générales ( x , y) liées à l’écran.
Son point d’application est lié à une pièce du mécanisme.
•
une action est dite « Lié pièce » si elle est fixe par rapport à
une pièce du mécanisme (direction et point d’application).
Les actions « Fixe »
Les actions « Lié pièce »
G
G
y 10 = y 0
BRIDE10
D0
C10=C0
G
y0
D0
BRIDE10
G
G
x10 = x 0
G
y 10
G
x10
G
y0
BATI
A la date t, action
G
x10
θ
G
x0
C10=C0
D0
BRIDE10
θ
BATI
A la date t=0, position de
référence
G
F
G
y 10
G
F
G
F
G
x0
C10=C0
BATI
G
F fixe
A la date t, action
G
F lié à la
pièce BRIDE10
Plusieurs types d’actions sont possibles :
ª Ressort, il faut préciser la longueur à vide du ressort et sa
raideur, ainsi que les pièces et les points d’accrochage.
ª Amortisseur, il faut préciser le coefficient d’amortissement,
ainsi que la liaison qui subit l’amortissement.
ª Vérin, il faut préciser les pièces et les points d’accrochage,
et l’intensité de la poussée si l’action est connue
ª Couple moteur, il faut préciser la liaison articulation qui est
motorisée ainsi que la valeur du couple (constant ou variable)
ª Pour les autres actions, on peut définir pour les problèmes
G
plans, deux composantes de résultantes (dans les directions x
G
G
et y ) et une composante de moment (autour de la direction z ).
Dans le cas d’une action inconnue, on peut préciser s’il existe
un moment transmissible (torseur) ou pas (glisseur ou force).
Lorsque vous déclarez les actions mécaniques au logiciel, il faut bien réfléchir à la nature
de vos données. En particulier, veillez à choisir avec soins les actions qui constituent les
données du problème et celles qui en constituent les inconnues. Un mauvais choix conduirait
à l’impossibilité du calcul.
25
D. MERTZ - MP-Wips.doc
Téléchargement
Explore flashcards