Le jeu L`algorithme à compléter

advertisement
2nde A
ALGORITHME EN AUTONOMIE : ALGORITHME ET PROBABILITE.
Activité 1 Simuler un lancer de dé à 6 faces. La FONCTION Random
1) La fonction random( ) permet d’obtenir un nombre décimal au hasard entre 0 et 1, 1 non compris.
On multiplie random( ) par………………. pour obtenir au hasard un nombre décimal entre 0 et 6, 6
non compris.
Et pour obtenir un nombre décimal entre 1 et 7 ( 7 non compris) on ajoute 1 : ………………………………
2) La fonction floor ( n) permet d’obtenir la partie entière du réel n.
Donc finalement pour obtenir un entier compris entre 1 et 6, on écrit :
…………………………………………….
3) Créer un algorithme permettant de simuler le lancer d’un dé à 6 faces non truqué.
4) Le modifier pour obtenir le lancer de trois dés à 6 faces simultanément.
ACTIVITE 2 Programmer un jeu : La boucle POUR …. ALLANT DE ….. A …..
Le jeu
L’algorithme à compléter
Var :
Le jeu consiste à lancer dix fois d’affiler un dé à 6 faces non
Dé
truqué :
Debut_Algo
On gagne 1 point si le nombre affiché est un nombre pair
On perd un point si le nombre affiché est un nombre
impair.
Ecrire dans Algobox un algorithme de ce jeu dont l’affichage
indiquera le nombre de point au bout des 10 lancer.
Compléter l’affichage avec un petit message.
Pour i allant de 1 à 10
Dé:=
Si Dé==2 ou Dé==4 ou Dé==6
Alors
sinon
Afficher
Fin_Algo
ACTIVITE 3 LA BOUCLE TANT …. QUE….
Le jeu
Le jeu consiste à lancer de deux dés à 6 faces et
additionner les deux faces tant que les nombres
sont différents.
La somme finale constitue le gain total.
Le jeu s’arrête dés qu’on obtient deux nombres
égaux. Et on remporte la somme totale.
Afficher le nombre de lancer et la somme totale.
L’algorithme à compléter
Var :
A ; B ; S ; Compteur
Deb_Algo :
S :=0
Compteur :=0
A :=
B :=
Si A==B Alors Afficher « Game Over »
Sinon
Tant que A !=B alors
Deb_Tant-que
A :=
B :=
compteur :=
S :=
Fin_Tant_que
Afficher : « Vous avez lancé les dés : »
Afficher compteur
Afficher : « fois. »
Afficher : « Vous avez remporté : »
Afficher S
Afficher : « points .»
Activite 4
Le jeu du 421.
Reprenez l’activité 1 et le lancer simultané de 3 dés puis créer un algorithme qui affiche « gagné » si le
tirage des trois dés donne les faces 4, 2 et 1 (dans l’ordre ou le désordre)
ACTIVITE 5 : Créer un jeu.
(Simulation - Instructions conditionnelles - Boucle Tant que - Boucle Pour - Boucles imbriquées)
’ordinateur a pensé à un nombre entier entre 0 et 1000.
Le joueur doit le deviner en un minimum de coups :
-
Il entre un nombre entier, la machine répond MOINS (ou plus petit) ou PLUS( ou plus
grand), jusqu’à ce qu’il trouve.
De plus la machine mémorise le nombre de tentatives et l’affiche.
ACTIVITE 6 : LE LIEVRE ET LA TORTUE
(Simulation - Instructions conditionnelles - Boucle Tant que - Boucle Pour - Boucles imbriquées)
À chaque tour on lance un dé.
Si le 6 sort, alors le lièvre gagne la partie, sinon, la tortue avance d’une case.
La tortue gagne lorsqu’elle a avancé de 6 cases.
1. Écrire un algorithme qui simule une partie et affiche le vainqueur.
2. Modifier cet algorithme afin de simuler n parties et de compter le nombre de parties gagnées par la tortue.
3. Le jeu est-il à l’avantage du lièvre ou de la tortue ?
CODE
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
DE L'ALGORITHME :
VARIABLES
n EST_DU_TYPE NOMBRE
m EST_DU_TYPE NOMBRE
k EST_DU_TYPE NOMBRE
DEBUT_ALGORITHME
n PREND_LA_VALEUR floor(random( )*1000)+1
k PREND_LA_VALEUR 0
AFFICHER "J'ai pensé à un nombre entre 0 et 1000"
AFFICHER "Tu vas chercher le nombre auquel j'ai pensé"
AFFICHER "Il faut que tu le devines en un minimum de coups"
AFFICHER "On commence. J'ai mon nombre, que proposes-tu ?"
LIRE m
TANT_QUE (m!=n) FAIRE
DEBUT_TANT_QUE
k PREND_LA_VALEUR k+1
SI (m>n) ALORS
DEBUT_SI
AFFICHER m
AFFICHER " est trop grand"
FIN_SI
SI (m<n) ALORS
DEBUT_SI
AFFICHER m
AFFICHER " est trop petit"
FIN_SI
LIRE m
FIN_TANT_QUE
AFFICHER "Bravo mais il t'a fallu "
AFFICHER k
AFFICHER " coups !"
AFFICHER "Veux-tu essayer de faire mieux ?"
FIN_ALGORITHME
Téléchargement