3.7. Les sous-formulaires

publicité
582659459
1 avril 2004
Centre de ressources tertiaire
Lycée Emmanuel Mounier
6 avenue Marcelin Berthelot – 38029 Grenoble CEDEX 2
 04 76 46 12 12  04 76 86 25 15  [email protected]
site web : http://crtg.ac-grenoble.fr/
TECHNIQUES ET MODES OPERATOIRES
ACCESS 2000, XP
Access est une marque déposée de la société Microsoft ®
Centre de Ressources Tertiaires de Grenoble
Jacques SORNET – Mars 2004
ACCESS est un logiciel de la catégorie « système de gestion de base de données relationnelles » qui
offre de nombreuses interfaces graphiques pour la construction des tables, des requêtes et des
formulaires d’écran ou des états imprimés.
Ce document propose quelques indications opératoires, non exhaustives, concernant ACCESS sous
différentes versions. Il est destiné à guider les étudiants lors de travaux en autonomie mais ne peut
prétendre se substituer au cours dispensé par l’enseignant.
SOMMAIRE
Ce sommaire renvoie aux chapitres par lien hypertexte.
Le caractère  placé à droite de chaque titre de chapitre renvoie au sommaire par lien hypertexte.
1.
ACCESS ET LA CREATION DE TABLES .................................................................... 4
1.1.
Le lancement et l'abandon d'ACCESS ......................................................................................................................... 4
1.2.
La création et la modification d’une table .................................................................................................................... 5
1.3.
L'indexation ACCESS .................................................................................................................................................... 6
1.4.
Les relations entre tables................................................................................................................................................ 7
1.5.
Modification de relations existantes .............................................................................................................................. 8
1.6.
La saisie et l’exploitation des données d’une table....................................................................................................... 9
1.7.
Méthode générale pour réaliser une base ACCESS .................................................................................................... 9
2.
LES REQUETES GRAPHIQUES ACCESS  ................................................................ 10
2.1.
Les requêtes sélection ................................................................................................................................................... 10
CRT, Grenoble – Jacques Sornet - 582659459
page 1/29
582659459
1 avril 2004
2.2.
Les types de jointures ACCESS .................................................................................................................................. 11
2.3.
Les calculs dans les requêtes ........................................................................................................................................ 12
2.4.
Le paramétrage des requêtes ....................................................................................................................................... 12
2.5.
Les requêtes action ....................................................................................................................................................... 13
2.6.
L’enchaînement des requêtes....................................................................................................................................... 14
3.
LES FORMULAIRES ACCESS  ................................................................................... 15
3.1.
Le formulaire ACCESS ................................................................................................................................................ 15
3.2.
La création et la modification d’un formulaire .......................................................................................................... 15
3.3.
La gestion des contrôles du formulaire ....................................................................................................................... 16
3.4.
Les types de contrôles courants ................................................................................................................................... 16
3.5.
L’utilisation des zones de liste pour pointer des enregistrements ............................................................................ 17
3.6.
Le rôle des formulaires ................................................................................................................................................. 18
3.7.
Les sous-formulaires..................................................................................................................................................... 19
3.8.
L’exécution des formulaires ......................................................................................................................................... 19
4.
LES IMPRESSIONS ET LES GRAPHIQUES ACCESS .............................................. 20
4.1.
Les documents imprimés par ACCESS ...................................................................................................................... 20
4.2.
L’impression d’étiquettes ............................................................................................................................................. 20
4.3.
La réalisation d’un état ................................................................................................................................................ 20
4.4.
L’insertion de graphique dans un formulaire ou un état .......................................................................................... 21
5.
LES IMPORTATIONS - EXPORTATIONS ACCESS / OFFICE  .................................. 22
5.1.
L’exportation de données vers EXCEL ...................................................................................................................... 22
5.2.
L’importation de données EXCEL ............................................................................................................................. 22
5.3.
L’exportation d’une liste de publipostage vers WORD ............................................................................................ 22
6.
COMPLEMENTS ACCESS  ......................................................................................... 23
6.1.
Les macro-instructions ................................................................................................................................................. 23
6.2.
L’usage d’un formulaire comme base d’une requête ................................................................................................ 24
6.3.
L’automatisation des importations - exportations ..................................................................................................... 25
7.
LES SECURITES ACCESS  ........................................................................................ 26
7.1.
Le partage d’applications ACCESS ............................................................................................................................ 26
CRT, Grenoble – Jacques Sornet - 582659459
page 2/29
582659459
1 avril 2004
7.2.
Le principe général de la sécurité au niveau utilisateur ............................................................................................ 26
7.3.
La gestion des comptes de groupes et d’utilisateurs .................................................................................................. 26
7.4.
Les types d’autorisations et leur attribution .............................................................................................................. 27
7.5.
Les groupes de travail .................................................................................................................................................. 28
7.6.
La protection des champs et contrôles ........................................................................................................................ 29
7.7.
Le contrôle des accès simultanés ................................................................................................................................. 29
CRT, Grenoble – Jacques Sornet - 582659459
page 3/29
582659459
1 avril 2004
1. ACCESS ET LA CREATION DE TABLES 
1.1. Le lancement et l'abandon d'ACCESS
 Le lancement d’ACCESS se fait par le menu Démarrer – Programmes de WINDOWS.
Il faut ensuite suivre les indications du logiciel pour ouvrir une base existante ou créer une nouvelle
base.
Ce choix (ouvrir une base ou en créer une nouvelle) peut également se faire par le menu Fichier
(options « Ouvrir » ou « Nouveau »).
 Le plan de travail ACCESS s'affiche à l’ouverture ou à la création d’une base :
 Pour quitter ACCESS, revenir au plan de travail et utiliser le menu Fichier - Quitter ou « double
cliquer » sur la clé ACCESS, dans le coin supérieur gauche de l'écran.
CRT, Grenoble – Jacques Sornet - 582659459
page 4/29
582659459
1 avril 2004
1.2. La création et la modification d’une table
Une base de donnée ACCESS comporte une ou plusieurs tables relationnelles, dans lesquelles des
données sont mémorisées.
 Pour créer une table :
-
cliquer sur l'objet tables puis sur « Nouveau » (mode création) :une grille de définition de table
s'affiche ;
définir chaque champ de la table dans cette grille (nom, type, puis onglet « Général » en bas
d’écran) ;
indiquer à ACCESS le ou les champs constituant la clé primaire (sans doublon) de la table en
-
sélectionnant la (les) ligne(s) de champ constituant la clé. Cliquer ensuite sur le symbole
du bandeau de haut d’écran ;
fermer la grille de définition, nommer la table et l’enregistrer.
-
Exemple de définition des tables de facturation :
 Les types de champs les plus courants sont les types:
-
texte, soit une suite de caractères quelconques (au plus 255) ;
mémo, soit un texte de longueur supérieure à 255 caractères (généralement utile pour la saisie
de commentaires libres ou de pages d’information) ;
numérique, soit une valeur utilisée dans des calculs (format entier < 32768, entier long, réel,
…) ;
CRT, Grenoble – Jacques Sornet - 582659459
page 5/29
582659459
-
1 avril 2004
date / heure, soit un repère temporel (date et heure complètes ou abrégées) ;
oui / non, soit l’expression d’une alternative ;
« numéroauto », soit l’attribution automatique d’un numéro séquentiel, du type entier long.
Remarque : seules les données intervenant dans des calculs doivent être d’un type numérique. Un code postal ou un numéro
de téléphone sont des données du type texte.
 Le type « Assistant liste de choix » permet, lorsque l’on saisit une donnée dans le champ, de choisir la
valeur du champ dans une liste présentant des valeurs provenant d’une autre table.
La construction de cette liste de choix se fait aisément en suivant les instructions de l’assistant (choix de
la table d’où proviennent les valeurs, des champs, …).
 Les propriétés optionnelles « Valide si » et « Null interdit » peuvent être attribuées au champ (onglet
« Général » situé en bas du cadre de définition de table). Elles permettent de définir une contrainte de
domaine (les valeurs acceptables pour le champ) ou d’imposer une saisie dans le champ.
La propriété « Masque de saisie » permet de définir une contrainte quant à la forme des données saisies
dans le champ (99999 indique par exemple que le champ code postal de type texte est, en fait, composé
obligatoirement de 5 chiffres).
 Une description de table peut ultérieurement être modifiée en sélectionnant au préalable la table dans
la liste affichée par ACCESS, puis en optant pour « Modifier ».
En particulier, un champ sélectionné peut être supprimé par la touche "Suppr" (ou « Del »), déplacé par
« clic maintenu ». Une nouvelle ligne de champ peut être intercalée par « Ins » (insertion).
Une table au préalable sélectionnée peut être renommée par le choix Edition - Renommer , recopiée
par Edition - Copier - Coller » ou supprimée par la touche « Suppr ».
1.3. L'indexation ACCESS
 Un index est sensé accélérer les accès aux données à partir de la valeur d’un champ.
ACCESS autorise la création de 32 index par table mais, en pratique, la multiplication des index alourdit
les traitements : un équilibre est à trouver entre les avantages et les inconvénients de l'indexation.
Un index ACCESS est identifié par un nom (éventuellement un nom par défaut attribué
automatiquement) et peut regrouper de 1 à 10 champs d'une table. Il est obligatoirement défini à partir
de champs de type texte, numérique, monétaire ou date/heure.
 Deux catégories d'index peuvent être définis sur une table ACCESS :
-
un index primaire, unique, sans doublon (propriétés « Oui-sans doublon » ;
un ou plusieurs index secondaires, avec ou sans doublon.
Un index primaire est automatiquement créé sur la clé primaire de la table ACCESS.
 Lors de la construction d'une table, un index peut être créé sur un champ simple en utilisant la
rubrique « Indexé » des propriétés « Générales » du champ.
CRT, Grenoble – Jacques Sornet - 582659459
page 6/29
582659459
1 avril 2004
Des index sur champs simples ou multiples peuvent plus généralement être créés depuis la fenêtre de
définition d’une table par le menu Affichage - Index :
- le nom donné à l'index est saisi dans la colonne de gauche ;
- la colonne « Nom du champ » permet de sélectionner le (ou les) champ(s) constituant l'index en
-
les choisissant dans la liste affichée par
(tous les champs suivant un nom d'index, jusqu'au
nom d'index suivant, constituent cet index) ;
un clic sur une des « Propriétés de l'index » permet d'accéder à des options précises de
définition ;
la fermeture de la fenêtre « Index » valide la définition effectuée et le retour au plan de travail
permet de l'enregistrer.
Le choix Affichage - Index donne accès à la définition complète des index de la table en cours.
L'effacement d'une ligne dans la liste des index permet de supprimer un index déjà créé.
Remarques :
- ACCESS crée automatiquement un index quand un champ porte un nom évoquant un identifiant
(numéro_xxx, code_xxx …). Il faut donc, le cas échéant, adapter ou supprimer cet index ;
- Pour faciliter la mise à jour des tables à clés composées de plusieurs champs, il est fortement recommandé de
leur attribuer un numéro automatique comme clé primaire. Les champs constituant la clé « naturelle » de la
table pourront constituer un ou plusieurs index secondaires avec ou sans doublons, selon le cas.
1.4. Les relations entre tables
 Les liens (pointages) existant entre tables sont appelés « relations » sous ACCESS.
Ces relations entre tables peuvent être représentées graphiquement et sont définies grâce aux opérations
qui suivent :
- depuis le plan de travail, cliquer sur l’icône ou choisir les options de menus « Outils » puis
« Relations » ;
- une fenêtre « Relations » apparaît. Utiliser le cadre « Ajouter une table » pour ajouter les
tables nécessaires à la définition des relations. Si ce cadre est absent, il peut être affiché par
les options « Relations » et « Afficher la table… » ;
- lier les champs en relation dans chaque table par un « clic maintenu» en partant du champ
qui est clé primaire ou index unique, en allant vers la duplication de ce champ. La table de
départ (table source) est la « Table/requête » et la table d'arrivée la « Table/requête liée »
selon la terminologie ACCESS (dans l'exemple, partir du « code client » dans « CLIENT» et
aller vers le « code client » dans « FACTURE ») ;
- une fenêtre de dialogue « Relations » s'affiche, qui permet de préciser les contraintes à
appliquer. Cliquer sur « Appliquer l'intégrité référentielle » et « Créer ». ACCESS indique par
 le côté « lié » (plusieurs factures peuvent être liées à un client) et par 1 le côté « source »
(l'origine unique du code client) de la contrainte d’intégrité référentielle.
Remarque : une contrainte d’intégrité référentielle est une règle qui impose que toute valeur saisie dans le champ lié soit
présente dans le champ source. ACCESS fait automatiquement cette vérification lors de la saisie de données, dès lors que
la contrainte d’intégrité référentielle est définie.
 D'autres options concernent les relations:
- « Mettre à jour en cascade » permet qu'une modification de valeur de la clé primaire de la
table source soit automatiquement répercutée dans les lignes des tables liées » ;
CRT, Grenoble – Jacques Sornet - 582659459
page 7/29
582659459
-
1 avril 2004
« Effacer en cascade » provoque l'effacement automatique des enregistrements liés quand
on supprime la source.
 A la fermeture de la fenêtre « relations », celles ci sont enregistrées.
Remarques :
- dans l’écran « Relations », les champs qui constituent ou participent à une clé primaire ressortent en
caractères gras ;
- la notation ACCESS sur les liens est INVERSE des cardinalités du SCD
(1 -->  et N ---> 1) ;
- une relation ne peut être établie entre un champ ACCESS de type "NuméroAuto" et un champ numérique
correspondant dans une autre table que si ce dernier est défini comme un "Entier long". De manière
générale, les champs en relation doivent avoir des définitions compatibles.
Exemple :
1.5. Modification de relations existantes
Pour accéder aux « Relations » ACCESS déjà enregistrées, procéder comme pour leur création.
L'affichage de toutes les relations fait apparaître à l'écran une image graphique complète de la structure
des tables relationnelles.
Une relation particulière peut être sélectionnée par « simple clic » sur le trait qui la représente, puis
supprimée par la touche « Suppr ». Un « double clic » sur ce trait permet d’accéder au cadre de
définition de la relation et de la modifier.
CRT, Grenoble – Jacques Sornet - 582659459
page 8/29
582659459
1 avril 2004
1.6. La saisie et l’exploitation des données d’une table
 Une table peut être ouverte en « Feuille de données » afin d’en travailler le contenu : ajout de lignes,
modifications ou suppressions. Une ou plusieurs lignes peuvent être sélectionnées par « simple clic » ou
« clic maintenu » sur la colonne de gauche de la feuille de données.
 Dans une table ouverte (et contenant des données), il est possible de passer d'un enregistrement à
l'autre à l'aide d'outils standards simples :
- par balayage séquentiel, en cliquant sur
pour aller au premier enregistrement, sur
pour aller au
dernier enregistrement, sur
ou sur
pour sauter à l'enregistrement précédent ou au suivant ;
- par recherche sélective, en cliquant sur le champ servant à la sélection puis sur l'icône
. Suivre
alors les indications de la fenêtre « Rechercher dans le champ : ... », saisir la valeur recherchée puis
choisir
et fermer la fenêtre de
recherche. ACCESS se positionne sur l'enregistrement correspondant s'il existe.
1.7. Méthode générale pour réaliser une base ACCESS
Pour réaliser une base il faut effectuer les tâches suivantes, dans l’ordre :
1) établir le schéma conceptuel des données ;
2) établir le schéma relationnel ;
3) créer les tables ACCESS (en précisant correctement la description de chaque champ et en
choisissant une clé primaire) ;
4) créer les relations entre les tables ainsi que les contraintes d’intégrité référentielles ;
5) créer un jeu d’essai (données destinées à tester la base) ou collecter les données réelles ;
6) saisir les données en respectant l’ordre imposé par les contraintes (une valeur doit être saisie
dans le champ « source » avant de l’être dans le champ « lié »).
Remarque : il est essentiel de ne pas saisir de données (6°) dans les tables avant d’avoir défini toutes les contraintes
s’appliquant aux données, notamment les contraintes d’intégrité référentielles. Ceci évitera des incohérences qui peuvent
ensuite nécessiter l’effacement de certaine relations, certaines données voire certaines tables pour être corrigées.
CRT, Grenoble – Jacques Sornet - 582659459
page 9/29
582659459
1 avril 2004
2. LES REQUETES GRAPHIQUES ACCESS 
2.1. Les requêtes sélection
L’interface graphique ACCESS (« QBE » - Query By Example -) distingue les requêtes sélection,
mise à jour, ajout, suppression de lignes et création de table.
 Pour réaliser une requête sélection sur une seule table :
- choisir
puis « Nouveau » ;
- dans la fenêtre « Nouvelle requête » choisir « Mode création » , les cadres « Requête Sélection »
et « Ajouter une table » sont ouverts (à défaut, il est possible d'afficher le cadre « Ajouter une
table » par le menu Requête- Ajouter une table) ;
- sélectionner la table utile puis « Ajouter » et fermer le cadre « Ajouter une table » ;
- un « clic maintenu» permet d'amener un à un les champs vers la grille en bas d’écran, qui
représente les champs utiles à la requête ;
- des précisions seront fournies pour chaque champ utile : sur la ligne « Afficher » (le champ ne
figurera pas dans le résultat de la requête si cette ligne n’est pas cochée), sur la ligne « Critères »
(où le critère de sélection est saisi) ;
-
fermer le cadre « Nouvelle requête » et suivre les indications pour la nommer et l’enregistrer.
Remarques:
- les valeurs des critères peuvent être alphanumériques ou numériques et être assorties de divers opérateurs de
comparaison (exemple : = ‘Dubois’, =’01/02/02’, >789, <=700) ou combinées (exemple : >100 ET
<150) ;
- en création ou modification de requête, le choix « Affichage » puis « Mode SQL » permet de visualiser l'ordre
SQL correspondant (ce SQL peut être modifié). Les choix Affichage - Création ramènent au cadre de requête ;
- la largeur d’une colonne du tableau du cadre « Requête » peut être modifiée par un « clic maintenu » sur le trait
séparateur des colonnes, tout en haut de celle-ci ;
- pour s’aider dans la construction d’un critère de sélection, il est possible d’utiliser le « générateur d’expression »
ACCESS, en cliquant sur l’icône
en haut de l’écran.
CRT, Grenoble – Jacques Sornet - 582659459
page 10/29
582659459
1 avril 2004
 Pour réaliser une sélection multitable (jointure) :
- ajouter les tables nécessaires. ACCESS détecte automatiquement un lien de jointure entre les
rubriques déjà mises en relation, ou entre les champs de même nom et de même définition ;
- faire glisser les rubriques nécessaires vers le tableau de bas d’écran, entrer le critère de sélection ;
- fermer la fenêtre, nommer, enregistrer la requête.
Remarques:
- il est possible de joindre deux tables par deux rubriques de même définition, mais qui n'ont pas le même nom ou
ne sont pas en relation, par un "clic maintenu" d'une rubrique à l'autre dans le cadre de requête ;
- à l'inverse, il est possible de supprimer un lien en le sélectionnant par simple-clic (il apparaît alors en gras) puis
en appuyant la touche "Suppr" ;
- on peut inclure dans le résultat de la requête des champs provenant de tables non-jointes (c'est le cas des
paramètres) ;
 pour exécuter la requête, la sélectionner puis choisir « Ouvrir ». Elle peut par ailleurs être
modifiée, supprimée, renommée, ... de façon similaire aux tables.
2.2. Les types de jointures ACCESS
Un double-clic sur le trait de relation affiché dans le cadre de requête donne accès à la définition
des « Propriétés de la jointure » :
- l’option « 1 » est implicite (il s’agit d’une équijointure interne, qui inclut dans le résultat
uniquement les lignes des tables pour lesquelles il y a égalité du champ de jointure) ;
- les options « 2 » et « 3 » correspondent à des jointures externes, incluant tous les
enregistrements de l’une des tables.
CRT, Grenoble – Jacques Sornet - 582659459
page 11/29
582659459
1 avril 2004
2.3. Les calculs dans les requêtes
ACCESS offre la possibilité d'intégrer des calculs simples et d’effectuer des agrégats dans une
requête :
- définir le champ de regroupement à l’aide de la ligne opérations (obtenue par le menu Affichage
- Opérations ou Affichage – Totaux selon la version du logiciel)
- choisir l’opération souhaitée.
2.4. Le paramétrage des requêtes
Le paramétrage d'une requête sélection permet de faciliter sa réutilisation : la valeur du critère de
sélection est alors saisie, dans un cadre proposé par ACCESS, à chaque exécution de la requête.
Pour paramétrer une requête, il faut saisir (entre crochets) un libellé libre dans la zone de critère du
champ considéré (par exemple = [Entrez le code article] ).
Ce libellé sera affiché par ACCESS lors de l’exécution de la requête, pour indiquer quelle valeur
doit être saisie.
Le paramétrage peut s’appliquer à des conditions combinées
(par exemple >[PU mini] ET <[PU maxi] ).
CRT, Grenoble – Jacques Sornet - 582659459
page 12/29
582659459
1 avril 2004
2.5. Les requêtes action
 Les requêtes action d’ACCESS permettent des manipulations ayant comme finalité la modification du
contenu des tables :
- la création d’une nouvelle table à partir d’enregistrements et de champs extraits d’une ou
plusieurs autres tables (requête création) ;
- la suppression de plusieurs enregistrements d’une table en fonction de critères déterminés
(requête suppression) ;
- l’ajout à une table d’une série d’enregistrements provenant d’une ou plusieurs autres tables
(requête ajout) ;
- la mise à jour des valeurs d’un ou plusieurs champs dans une table (requête mise à jour).
 Pour accéder à la définition des requêtes action, il faut entrer en création de requête, sélectionner la
table (les tables si l’on souhaite faire un ajout ou une création à partir d’une jointure) constituant la
source des données, puis choisir le type de requête souhaité dans le menu « Requête » :
Suivre ensuite les indications (choix de la table de destination, …).
Remarque : en ajout ou création, le champ de la table cible est automatiquement généré sur la ligne « Ajouter à » si son
nom est identique à celui du champ dans les autres tables. Sinon, il faut choisir le champ de destination dans la liste
ouverte en cliquant sur la cellule « Ajouter à » appropriée.
CRT, Grenoble – Jacques Sornet - 582659459
page 13/29
582659459
1 avril 2004
2.6. L’enchaînement des requêtes
Une requête peut être basée sur une autre requête, ou sur des requêtes et des tables.
Pour réaliser un tel enchaînement il faut, lors de la création de la requête, choisir selon le cas la source
de la requête dans l’onglet « Requête » ou « Les deux », au lieu de l’onglet « Ajouter une table ».
Dès lors, les requêtes s’enchaînent, le résultat de l’une servant d’entrée à la suivante.
L’ouverture de la dernière requête de la chaîne provoquera l’enchaînement de toutes les requêtes depuis
la première.
CRT, Grenoble – Jacques Sornet - 582659459
page 14/29
582659459
1 avril 2004
3. LES FORMULAIRES ACCESS 
3.1. Le formulaire ACCESS
 Le terme formulaire (du nom des documents que l’on remplit lors de diverses formalités) désigne,
sous ACCESS, un façon de présenter des données sur un écran.
Le formulaire diffère de la présentation en feuille de données, car seules les informations nécessaires
sont présentées selon une organisation adaptée au problème à traiter. La construction de formulaires
permet de bâtir des applications plus ergonomiques et plus sûres qu’avec le mode « feuille de données ».
 On appelle « contrôles » les rubriques qui figurent dans un formulaire :
- un contrôle lié (ou dépendant) est lié au champ d’une table. La valeur saisie dans ce contrôle est
automatiquement enregistrée dans la ligne en cours de la table utilisée ;
- un contrôle indépendant ne correspond à aucun champ de table.
La valeur prise par un contrôle peut être utilisée ailleurs dans le formulaire ou dans un autre traitement.
3.2. La création et la modification d’un formulaire
 Un assistant permet de produire très facilement des formulaires standardisés, qui peuvent être
modifiés pour mieux correspondre aux besoins d’une application.
Pour créer un formulaire avec l’assistant :
- choisir l’objet « Formulaires » du plan de travail ACCESS, puis « Nouveau » et
« assistant formulaire» ;
- choisir la table ou la requête sur laquelle sera basé le contenu du formulaire (à l’aide de la liste
affichable), puis déterminer son contenu (les champs souhaités) et sa présentation ;
- afficher et tester le formulaire, ou passer en modification si le modèle généré automatiquement doit
être adapté.
Un formulaire terminé est nommé et enregistré. Il peut ensuite être exécuté ou modifié (sélection, choix
« Ouvrir » ou « Modifier »), ou encore recopié (Edition - Copier - Coller).
 En modification de formulaire, comme en mode création sans assistant, un cadre de formulaire
apparaît.
Le fond du formulaire peut être redimensionné par « clic maintenu » sur ses contours. Des contrôles
peuvent y être ajoutés ou supprimés.
 Chaque élément du formulaire (ensemble du formulaire, contrôle, section, fond) dispose de
propriétés qui peuvent être affichées puis modifiées, après sélection de l’élément concerné par « simple
- clic », grâce au menu Affichage - Propriétés.
CRT, Grenoble – Jacques Sornet - 582659459
page 15/29
582659459
1 avril 2004
Remarques :
- pour voir les propriétés générales du formulaire, il faut au préalable le sélectionner en cliquant sur l’angle supérieur
gauche
du cadre formulaire ;
- pour que les différentes aides des assistants soient disponibles, l’icône
de la boite à outils doit être en surbrillance (à défaut, un « simple clic » sur ce symbole permet de passer sous
assistance).
 Un formulaire peut comporter plusieurs sections (entête, détail, pied de page notamment).
3.3. La gestion des contrôles du formulaire
 Pour ajouter un contrôle dans un formulaire, la boite à outils et / ou la liste des champs de la table ou
de la requête sur laquelle est basé le formulaire doivent être affichées (à défaut, utiliser les menus
Affichage – Boite à outils et Affichage – Liste des champs) :
- tirer un champ depuis la liste vers le formulaire pour l’y ajouter (« clic maintenu ») ;
- sélectionner une option dans la boite à outil (« simple clic ») puis placer cette option dans le formulaire
(« simple clic ») pour l’y insérer.
 ACCESS attribue un nom unique à chaque contrôle, qui est visible dans les propriétés du contrôle
(onglet « Autres »).
Remarque : le nom d’un contrôle est modifiable. Toutefois, le nom de contrôle est parfois utilisé dans des procédures de
traitement VBA générées par ACCESS (voir l’onglet Evénements), il est donc préférable de ne pas le changer.
 Chaque contrôle peut être déplacé ou redimensionné par « clic maintenu », et supprimé après sa
sélection en utilisant la touche « Suppr ».
Plusieurs contrôles (une zone) du formulaire peuvent être sélectionnés simultanément en utilisant le
de la boîte à outils, et être traités globalement (déplacement, suppression, changement de propriétés,
…).
L’ordre dans lequel les contrôles sont activés lors de l’exécution du formulaire (par exemple pour y
saisir des valeurs) peut être modifié par le menu Affichage - Ordre de tabulation.
3.4. Les types de contrôles courants

Intitulé (texte simple) : libellé à saisir après avoir introduit le contrôle dans le formulaire depuis la
boite à outils (
)

Zone de texte dépendante : il s’agit d’un champ de table. Ce contrôle est obtenu à partir de la liste
des champs de la table ou de la requête associée au formulaire, ou bien il est généré automatiquement
par l’assistant. Une étiquette lui est associée (en standard le nom du champ). L’étiquette peut être
sélectionnée, modifiée ou supprimée par les manipulations usuelles Microsoft.

Zone de texte indépendante : équivalente à la zone dépendante, mais sans liaison avec une table.
La zone indépendante est utile pour faire un calcul ou assurer une mémorisation intermédiaire. Elle est
obtenue à partir de la boite à outils (
CRT, Grenoble – Jacques Sornet - 582659459
).
page 16/29
582659459
1 avril 2004

Zone calculée : zone de texte indépendante dans laquelle on saisit une formule de calcul
commençant par le signe =. La formule peut faire référence aux noms des autres contrôles du
formulaire, contenir des constantes et appeler des fonctions standard. Un générateur d’expression est
accessible par la manœuvre suivante :
- sélectionner le contrôle calculé, puis afficher ses propriétés ;
- dans l’onglet « Données », rubrique « Source contrôle », cliquer sur
et suivre les indications.

Zone de liste : ce contrôle propose, lors de l’exécution du formulaire, une liste de valeurs prises
dans une table ou une requête. Une nouvelle valeur peut être saisie s’il s’agit d’une liste modifiable,
seules les valeurs préexistantes sont autorisées s’il s’agit d’une liste simple.
Un assistant à la création d’une liste est automatiquement lancé si l’icône
de la boîte à outils est
sélectionnée (en surbrillance) avant la création du contrôle par les outils
(liste simple).
(liste modifiable) ou
Le contrôle de type liste est particulièrement utile car il évite des saisies et permet de garantir l’intégrité
référentielle.
Remarques :
- une liste est automatiquement générée quand on insère une zone de texte dépendante correspondant à un champ de
type liste de choix ;
- une liste peut comporter plusieurs rubriques d’une même table ou requête, l’une d’entre elles peut être cachée
(généralement la clé de la table).

Bouton de contrôle : permet de déclencher un traitement (suppression d’enregistrement,
fermeture du formulaire, ouverture d’un autre formulaire, exécution d’une requête, etc …). Par défaut,
le traitement concerne l’enregistrement ou le formulaire en cours.
Le bouton est inséré par l’outil
ACCESS.
, en suivant les indications détaillées fournies par l’assistant
L’utilisation de boutons de contrôle déclenchant des formulaires permet d’enchaîner les écrans et de
construire très facilement un menu général, où des boutons assurent le lancement des différents
formulaires, des requêtes ou des états.
3.5. L’utilisation des zones de liste pour pointer des
enregistrements
 Une liste permet de choisir la valeur à inscrire dans un champ.
Une zone de liste peut être utilisée pour pointer une ligne dans une table à l’aide de la valeur d’un de ses
champs (notamment de sa clé). Pour ceci il faut:
- créer un formulaire associé à la table concernée ;
- ajouter au formulaire une liste modifiable basée sur le champ de recherche en optant pour
;
-
insérer les autres champs dans le formulaire.
Le formulaire obtenu se positionnera automatiquement sur l’enregistrement correspondant à la valeur
choisie dans la liste, pour lecture ou modification.
CRT, Grenoble – Jacques Sornet - 582659459
page 17/29
582659459
1 avril 2004
Remarques :
- cette dernière technique n’est pas utilisable pour des recherches sur plusieurs champs simultanément, il faut alors
recourir à d’autres procédés comme les requêtes ou les sous –formulaires ;
- cette option génère un contrôle indépendant, qui ne peut être utilisé pour créer ou modifier une table (notamment en
cas de création). Pour effectuer cette opération, il faut intégrer au formulaire, en plus de la zone de liste qui sert à la
sélection, un contrôle dépendant portant sur le champ concerné. Ce contrôle permettra de saisir la nouvelle valeur du
champ.
3.6. Le rôle des formulaires
Les formulaires permettent de différencier, pour une même table, la création, la mise à jour suppression ou la simple lecture des données. A cet effet, le rôle de chaque formulaire peut être précisé
dans l’onglet « Données » des propriétés du formulaire.
Exemple : l’image d’écran ci-dessous montre un formulaire en cours de construction. On y voit le fond quadrillé du
formulaire, les propriétés « données » du formulaire. Ce formulaire sera utilisable uniquement pour créer un nouvel article
(les propriétés modification et suppression sont positionnées à « non » . Cette image d’écran montre aussi les rubriques de
la table sur laquelle est basé le formulaire et la « boite à outils ».
CRT, Grenoble – Jacques Sornet - 582659459
page 18/29
582659459
1 avril 2004
3.7. Les sous-formulaires
 L’insertion d’un sous-formulaire dans un formulaire principal permet d’afficher et de traiter des
données provenant de deux tables entre lesquelles existe une relation  - 1 ACCESS (un lien un à
plusieurs 1 - N dans le schéma conceptuel des données).
Le sous-formulaire affiche les enregistrements qui correspondent à l’enregistrement en cours dans le
formulaire principal.
Exemple :
 Pour créer un formulaire avec sous - formulaire, en partant de deux tables liées par une relation un à
plusieurs:
- choisir Formulaire et Nouveau ;
- dans le cadre Nouveau formulaire, cliquer sur Assistant formulaire ;
- sélectionner la table située du côté marqué « 1 » des relations ACCESS (ou la requête d’où
proviendront les données du formulaire principal) ;
- inclure les champs souhaités dans le formulaire principal ;
- sélectionner ensuite la table située du côté «  » (ou la requête d’où proviendront les données du
sous - formulaire) ;
- inclure les champs souhaités dans le sous – formulaire ;
- choisir « suivant » et suivre les instructions.
 Le formulaire étant créé, il peut être modifié et amélioré (cadrage, présentation générale, insertion
d’une liste modifiable de choix dans le formulaire principal, modification des propriétés du formulaire
principal ou du sous formulaire, …).
Le sous - formulaire peut notamment être particularisé pour des créations, des modifications ou en
lecture seulement.
Remarque : un sous-formulaire peut être ajouté à un formulaire déjà existant en passant par la boite à outils et l’outil
« Sous formulaires / sous états ».
3.8. L’exécution des formulaires
Pour exécuter un formulaire, choisir Objets - Formulaires sur le plan de travail ACCESS, sélectionner
un formulaire et choisir « Ouvrir ».
La fermeture du formulaire provoque automatiquement la mise à jour de la table qui lui est associée.
CRT, Grenoble – Jacques Sornet - 582659459
page 19/29
582659459
4. LES IMPRESSIONS ET LES GRAPHIQUES ACCESS
1 avril 2004

4.1. Les documents imprimés par ACCESS
ACCESS permet de restituer le contenu d’une base de données sous la forme d’états imprimés,
d’étiquettes ou de graphiques (pour des données numériques).
Ces opérations sont facilitées par les assistants état, étiquette et graphique.
4.2. L’impression d’étiquettes
Choisir Objets - Etats puis Nouveau, Assistant Etiquette, sélectionner la table ou la requête d’où
proviennent les données.
Les étiquettes seront aisément obtenues en suivant les indications de l’assistant.
4.3. La réalisation d’un état
 Choisir Objets - Etats puis Nouveau, Assistant Etat, valider par OK.
Le cadre ACCESS propose le choix de tables ou de requêtes d’où proviennent les données à faire
figurer dans l’état. Plusieurs origines peuvent être combinées et l’on choisit ensuite les champs à
intégrer dans l’état.
Dans le cas d’origines multiples, la table ou la requête qui dirige l’impression de l’état doit ensuite être
définie (« … afficher les données par …. »), l’effet obtenu est visualisé à l’écran.
Un ou plusieurs niveaux de regroupement peuvent être spécifiés (on regroupe par exemple les lignes
commandées par commande). Le tri des lignes est possible.
Pour terminer, l’état est vérifié par impression simulée à l’écran, puis nommé et enregistré.
 Un état généré par l’assistant peut être modifié de la même façon qu’un formulaire (modification des
étiquettes ou des titres de colonnes, ajout de contrôles calculés, changement de propriétés, …).
Chaque état comporte plusieurs sections (état, page, groupe, détail) et chaque section peut disposer
d’une entête et d’un pied.
Le cadre de travail sur un état se présente comme suit :
CRT, Grenoble – Jacques Sornet - 582659459
page 20/29
582659459
1 avril 2004
 Pour effectuer un calcul concernant un niveau de regroupement de données, il faut intégrer un
contrôle indépendant dans le pied de groupe correspondant et y formuler le calcul à l’aide des
opérateurs usuels et des fonctions standard ACCESS.
Les fonctions (SOMME, MOYENNE, MAX, MIN, …) qui portent sur des contrôles inclus dans le
formulaire doivent faire référence aux noms attribués à ces contrôles (voir Affichage – Propriétés –
Autres), placés entre crochets.
Exemple : ci-dessus, la somme porte sur le contrôle de nom « quantité ».
Cette opération peut présenter quelques difficultés :
- l’assistant ACCESS ne génère pas systématiquement les pieds de groupe. Pour faire apparaître si
nécessaire le pied de groupe souhaité, sélectionner l’en-tête de la section, puis le menu Affichage - Trier
et grouper, choisir Oui dans l’option pied de groupe ;
- quand une fonction porte sur un contrôle qui est lui-même calculé, il faut répéter ce calcul dans la
fonction, si nécessaire en utilisant les noms des champs de table (on ne peut pas se contenter de citer le
nom du champ calculé).
4.4. L’insertion de graphique dans un formulaire ou un état
Le graphique est réalisé à partir du menu Insertion - Graphique et en suivant les indications de
l’assistant (l’assistant doit au préalable être installé, en option).
L’assistant ACCESS affiche un graphique « standard ». Pour obtenir l’image réelle, il faut obtenir un
Aperçu avant impression ou bien Ouvrir le formulaire.
CRT, Grenoble – Jacques Sornet - 582659459
page 21/29
582659459
1 avril 2004
5. LES IMPORTATIONS - EXPORTATIONS ACCESS / OFFICE 
5.1. L’exportation de données vers EXCEL
Le contenu d’une table ACCESS (ou d’une requête) peut être transféré vers une feuille de calcul
EXCEL :
- sélectionner la table ou la requête ;
- menu Fichier – Exporter ;
- nommer la feuille de calcul, choisir le type EXCEL adapté ;
- valider l’exportation.
5.2. L’importation de données EXCEL
Les données d’une feuille de calcul EXCEL peuvent être transférées dans une table ACCESS :
- menu Fichier - Données externes – Importer ;
- choisir le type de fichier (.xls) et le sélectionner ;
- ACCESS affiche le contenu de la feuille de calculs ;
- après le choix « suivant », il est possible de retenir comme noms de champs les libellés situés en
tête des colonnes EXCEL ;
- ACCESS propose ensuite de créer une nouvelle table ou d’enregistrer les données dans une table
existante (la définition des champs de la table doit être compatible avec les données de la feuille
EXCEL) ;
- dans le cas d’une nouvelle table, des indications sont fournies pour définir sa clé primaire et les
noms de champs ;
- la table ACCESS est créée à la fin du processus.
5.3. L’exportation d’une liste de publipostage vers WORD
Une table ou une requête peut être exportée vers un fichier de source de données de fusion du
traitement de texte WORD :
- sélectionner la table ou la requête ;
- menu Fichier – Exporter ;
- choisir le type Microsoft Word Merge (*.txt) ou Fusion avec Microsoft ;
- nommer et valider l’exportation.
Ce fichier sera utilisable pour un publipostage WORD.
CRT, Grenoble – Jacques Sornet - 582659459
page 22/29
582659459
1 avril 2004
6. COMPLEMENTS ACCESS 
6.1. Les macro-instructions
 Une macro-instruction ACCESS est un programme de traitement composé de quelques instructions
synthétiques, appelées actions.
Exemples d’actions ACCESS : DéfinirValeur (définit la valeur d’un contrôle), OuvrirFormulaire (provoque l’ouverture
d’un formulaire), Actualiser (pour réinitialiser le contenu d’un contrôle quand on a changé d’enregistrement),
AtteindreEnregistrement (positionne sur un enregistrement particulier de la table), ExécuterSql (exécution d’un ordre
SQL).
Une action nécessite des paramètres d’exécution (valeur, référence à un champ ou un contrôle,
condition de sélection, ordre SQL, …).
 Le générateur de macros (lancé par Objets - Macros – Nouveau) permet de construire les macros. Il
présente la liste des macro-instructions possibles et précise les paramètres nécessaires à chaque macro :
 Chaque macro ACCESS est nommée, enregistrée et peut être ouverte, modifiée ou supprimée comme
les autres objets.
 Les macros permettent notamment d’affiner la réaction des formulaires et d’établir des liens entre
différents formulaires ou entre un formulaire et une requête.
Des macros peuvent être attachées aux formulaires et être déclenchées automatiquement lors de
certains événements (qui figurent dans l’onglet Evénements des propriétés d’un formulaire ou d’un
contrôle). Pour générer une macro associée à un événement, il suffit de cliquer sur le
de
l’événement concerné et d’activer le générateur de macro:
CRT, Grenoble – Jacques Sornet - 582659459
page 23/29
582659459
1 avril 2004
 Si une macro est nommée Autoexec, elle est automatiquement exécutée à l’ouverture d’une base de
données.
Créer une telle macro contenant l’action OuvrirFormulaire et désignant un formulaire construit pour
former un « menu général » permet donc de lancer automatiquement le premier écran d’une application.
6.2. L’usage d’un formulaire comme base d’une requête
 La valeur d’un contrôle contenu dans un formulaire peut être désignée par le nom complet du
contrôle, sous la forme [Formulaires] ! [nom du formulaire] ! [nom du contrôle], et reprise par ce nom
dans un autre formulaire, dans un calcul ou comme critère de sélection dans une requête.
Remarque : il est IMPERATIF d’utiliser le mot-clé Formulaires au pluriel.
Exemple : [Formulaires] ![SAISIE-ART] ![code] .
Un générateur d’expressions peut aider à la construction des formulations complexes.
 La liaison entre des valeurs saisies dans un formulaire et une requête où ces valeurs servent de critère
de sélection se fait de la façon suivante:
- créer la requête sans préciser les critères de sélection, la nommer et l’enregistrer ;
- créer un formulaire où seront saisies la ou les valeurs servant de critères de sélection (par exemple à
l’aide de listes de choix), noter les noms attribués par ACCESS à ces contrôles (ces noms sont en
standard du type ModifiableX) ;
- insérer dans le formulaire un bouton de contrôle, y choisir Divers – Exécuter une requête et
désigner la requête précédemment créée ;
- enregistrer le formulaire (par exemple sous le nom « source ») ;
- modifier la requête, y ajouter la référence aux contrôles du formulaire comme critères de sélection.
Par exemple : =[formulaires] ![source] ![modifiable0] si un critère est entré dans le contrôle nommé
modifiable0.
Dès lors, l’ouverture du formulaire (« source ») permet de saisir les critères de sélection, puis de
déclencher directement la requête en cliquant sur le bouton de contrôle.
 De nombreuses variantes de ce procédé sont possibles, par exemple :
-
-
-
déclenchement automatique de la requête lors de la saisie d’un critère. Il faut pour ceci ajouter en
propriété du contrôle, onglet Evénement et « Après MAJ » une macro-instruction utilisant l’action
OuvrirRequête pour lancer la requête ;
affichage du résultat de la requête dans un autre formulaire. Il faut pour ceci créer un formulaire
basé sur la requête et utiliser un bouton ou une action ouvrant ce formulaire (au lieu de déclencher
la requête comme précédemment) ;
déclenchement d’un état basé sur la requête.
CRT, Grenoble – Jacques Sornet - 582659459
page 24/29
582659459
1 avril 2004
6.3. L’automatisation des importations - exportations
Les opérations d’import-export peuvent être automatisées par des macro-instructions de type
« Transfert » : il faut créer une macro ACCESS commandant le transfert, chaque ouverture de la macro
provoquera ensuite le transfert des données.
Exemple : la macro ci-dessous permet d’exporter le résultat d’une requête ACCESS vers EXCEL (on peut aussi
exporter une table).
Le fichier de destination (ou d’origine en cas d’importation) doit être complètement défini (chemin
d’accès complet).
CRT, Grenoble – Jacques Sornet - 582659459
page 25/29
582659459
1 avril 2004
7. LES SECURITES ACCESS 
7.1. Le partage d’applications ACCESS
Les applications développées sous ACCESS peuvent être à usage individuel, ou être partagées entre
plusieurs utilisateurs.
Les sécurités ACCESS permettent de gérer un ensemble de protections des accès aux bases de données
partagées, notamment une protection au niveau des utilisateurs, qui doivent s’identifier et possèdent des
droits sur certains objets de la base.
7.2. Le principe général de la sécurité au niveau utilisateur
Des comptes de groupes et des comptes d’utilisateurs sont définis. Les utilisateurs peuvent s’intégrer
dans des groupes. L’ensemble des informations définissant les autorisations d’accès est rattaché à un
groupe de travail.
Attention : ne pas confondre « compte de groupe » (notion liée à l’usage d’une base de données) et « groupe de travail »
(élément du système d’administration des autorisations).
Chaque utilisateur dispose d’un nom et d’un mot de passe qui permettent de l’identifier.
7.3. La gestion des comptes de groupes et d’utilisateurs
 Le menu « Gestion des utilisateurs et des groupes » donne accès à la création ou la suppression de
groupes et d’utilisateurs, à la définition des mots de passe, et au rattachement des utilisateurs aux
groupes.
ACCESS crée en standard l’utilisateur « Administrateur » avec un mot de passe vierge, et deux groupes :
« Administrateurs » et « Utilisateurs ».
Tout nouvel utilisateur est obligatoirement rattaché au groupe « Utilisateurs » et dispose d’un mot de
passe vierge. Le groupe « Utilisateurs » ne dispose d’aucun droit sur les objets préexistant à la création
du groupe de travail, mais dispose de tous les droits sur les nouveaux objets.
Le (ou les) utilisateur(s) du groupe « Administrateurs » a(ont) seul(s) le droit de modifier les
autorisations d’accès et de créer des comptes d’utilisateurs ou de groupes.
Le groupe « Administrateurs » doit obligatoirement contenir au moins un utilisateur.
 Pour déclencher la connexion des utilisateurs (la vérification de leur identité à l’ouverture d’une
session d’utilisation des bases de données), il faut remplacer le mot de passe vierge de l’utilisateur
« Administrateur » par un mot de passe particulier.
A l’inverse, la connexion est supprimée si l’on supprime ce mot de passe.
CRT, Grenoble – Jacques Sornet - 582659459
page 26/29
582659459
1 avril 2004
Exemple de cadre de connexion :
A sa première connexion, l’utilisateur doit saisir son nom, puis ouvrir une base de données et créer son
mot de passe (menu Outils - Sécurité - Gestion des utilisateurs et des groupes, onglet Changer de mot
de passe). Lors de ses connexions ultérieures, cet utilisateur devra saisir nom et mot de passe.
7.4. Les types d’autorisations et leur attribution
 Des autorisations explicites peuvent être accordées à chaque utilisateur. Les autorisations implicites
sont accordées à un groupe : chaque utilisateur ajouté au groupe hérite des autorisations du groupe.
Les options de sécurité ACCESS sont accessibles par le menu Outils - Sécurité :
 L’attribution des droits d’accès se fait par le menu « Autorisations d’accès ». Des autorisations
détaillées peuvent être accordées sur les objets de la base (tables, requêtes, formulaires, ….) aux groupes
ou aux utilisateurs.
Seul un membre du groupe « Administrateurs », un utilisateur possédant le droit d’administrer l’objet ou
le propriétaire de l’objet peut attribuer des droits.
CRT, Grenoble – Jacques Sornet - 582659459
page 27/29
582659459
1 avril 2004
 Des autorisations d’accès (Ouvrir/exécuter, Lire la structure, Modifier la structure, Lire les données,
Modifier les données, Ajouter des données, Supprimer des données ou Administrer) sont attribuées sur
les objets de la base (tables, formulaires, états, macros et requêtes notamment).
Ces autorisations peuvent être attribuées directement aux utilisateurs. Toutefois, l’organisation des
entreprises fait qu’il est généralement plus adapté d’attribuer les droits à des groupes, puis de rattacher
les comptes d’utilisateurs à ces groupes. Les utilisateurs héritent automatiquement des autorisations des
groupes auxquels ils appartiennent.
7.5. Les groupes de travail
 Le groupe de travail décrit un environnement d’utilisation des bases de données. Il regroupe plusieurs
utilisateurs, les bases qu’ils exploitent et les autorisations associées.
Le groupe de travail est matérialisé par un fichier système d’extension .mdw.
 Le groupe de travail standard « system.mdw » est créé par défaut à l’installation d’ACCESS . Il est
rangé dans un répertoire système.
Afin de maîtriser les sécurités, il est préférable de créer un nouveau groupe au nom et à l’emplacement
appropriés. Ce groupe, utilisé pour définir les autorisations d’un ensemble d’utilisateurs, devra leur être
accessible : il peut être placé dans un répertoire partagé du serveur, avec les bases concernées.
Pour créer un groupe de travail, la méthode diffère selon les versions d’ACCESS :
- sous ACCESS 2000, il faut localiser l’utilitaire wrkgadm.exe (par la fonction Rechercher du
menu Démarrer) puis l’exécuter (« double clic »)
- avec ACCESS XP, il suffit de lancer ACCESS puis d’exécuter le menu Outils - Sécurité Administrateur de groupe de travail.
CRT, Grenoble – Jacques Sornet - 582659459
page 28/29
582659459
1 avril 2004
Le groupe de travail étant créé, il devient automatiquement actif, et les différents paramètres de sécurité
y sont stockés.
 Pour rejoindre un groupe et y travailler, la procédure est similaire à la création de groupe, en
choisissant l’option « Rejoindre ».
Plusieurs groupes de travail peuvent être définis.
Un utilisateur qui rejoint un groupe de travail (il se « connecte » au groupe) se voit soumis aux contrôles
d’accès et aux autorisations mémorisées pour ce groupe (et ce pour toutes les bases ACCESS).
Remarque : il suffit qu’un utilisateur ACCESS se connecte à un groupe depuis son poste de travail pour qu’ensuite toute
activation d’ACCESS sur ce poste déclenche les contrôles liés à ce groupe de travail. Le groupe utilisé précédemment par
ACCESS reste implicitement le groupe en vigueur lors du lancement suivant d’ACCESS.
7.6. La protection des champs et contrôles
La sécurité ACCESS concerne globalement un objet (table, formulaire, …).
Pour protéger certains champs de tables, il faut définir plusieurs formulaires, adaptés à chaque
utilisateur, où figureront uniquement les champs et contrôles autorisés, ou bien dans lesquels les
contrôles qui ne doivent pas être modifiés seront verrouillés (Propriétés, onglet Données, Verrouillé =
Oui).
7.7. Le contrôle des accès simultanés
Lorsque plusieurs utilisateurs travaillent sur une même base, ils peuvent vouloir accéder simultanément
aux mêmes données. Ceci ne présente pas d’inconvénient si chacun se contente de lire les données.
Mais si un utilisateur modifie les données en cours d’examen par un autre, il y a risque d’incohérence.
Exemple : un commercial consulte le stock d’un article pour informer son client, pendant qu’un autre valide une
commande pour ce même article et annule de fait le stock précédent qui est affiché sur l’écran du premier.
Dans cette situation, la cohérence de fonctionnement de l’application peut être prise en charge par
ACCESS. Un verrou peut être posé sur une table ou une ligne de table quand celle-ci est en cours de
modification par un utilisateur.
Le menu Outils - Options - Avancé permet d’opter pour :
- l’absence de protection (choix « Aucun ») ;
- le blocage de la table toute entière quand un champ est en cours de modification (choix
« Général ») ;
- le blocage de la ligne de table en cours de modification (choix « Enregistrement modifié »).
CRT, Grenoble – Jacques Sornet - 582659459
page 29/29
Téléchargement
Explore flashcards